diff mbox series

[bug#67271] gnu: at-spi2-core: Honor tests? flag..

Message ID bf2ddc3cec23a5127384cfb840344d2702300cc0.1700387396.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#67271] gnu: at-spi2-core: Honor tests? flag.. | expand

Commit Message

Zheng Junjie Nov. 19, 2023, 9:52 a.m. UTC
* gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.

Change-Id: Ie38226c0ceacd7afb54adff073c1f71eb596e10d
---
 gnu/packages/gtk.scm | 46 ++++++++++++++++++++++----------------------
 1 file changed, 23 insertions(+), 23 deletions(-)


base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523

Comments

Mathieu Othacehe Nov. 25, 2023, 1:43 p.m. UTC | #1
Hello,

> * gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.

Could you please rebase it on top of
9210ca9b0498d3360ee247841a6bd212d6aa8ec4?

Thanks,

Mathieu
Zheng Junjie Nov. 29, 2023, 10:51 a.m. UTC | #2
Mathieu Othacehe <othacehe@gnu.org> writes:

> Hello,
>
>> * gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.
>
> Could you please rebase it on top of
> 9210ca9b0498d3360ee247841a6bd212d6aa8ec4?

sorry, this patch should prefix with [PATCH gnome-term]

>
> Thanks,
>
> Mathieu
Maxim Cournoyer Dec. 31, 2023, 6:09 a.m. UTC | #3
Hi,

Mathieu Othacehe <othacehe@gnu.org> writes:

> Hello,
>
>> * gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.
>
> Could you please rebase it on top of
> 9210ca9b0498d3360ee247841a6bd212d6aa8ec4?

Is this core-updates?
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 67611efaae..745c3a9a55 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -811,31 +811,31 @@  (define-public at-spi2-core
            (delete 'check)
            ;; The CI test suite fails completely on powerpc-linux.
            ;; The name org.gnome.SessionManager was not provided by any .service
-           ;; TODO: Wrap 'check phase with 'tests?'.
            #$@(if (not (target-ppc32?))
                 #~((add-after 'install 'check
-                     (lambda _
-                       ;; xfconfd requires a writable HOME
-                       (setenv "HOME" (getenv "TMPDIR"))
-                       ;; dbus-run-session may crash if XDG_DATA_DIRS has too
-                       ;; many entries, maybe related to
-                       ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
-                       (setenv "XDG_DATA_DIRS"
-                               (string-append
-                                #$output "/share:"
-                                #$(this-package-native-input
-                                   "gsettings-desktop-schemas")
-                                "/share"))
-                       ;; Don't fail on missing  '/etc/machine-id'.
-                       (setenv "DBUS_FATAL_WARNINGS" "0")
-                       (with-directory-excursion (string-append "../at-spi2-core-"
-                                                                #$version "")
-                         (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
-                         (substitute* "ci/run-tests.sh"
-                           (("ps auxwww") "")   ;avoid a dependency on procps
-                           (("meson test -C _build")
-                            "meson test -C ../build")) ;adjust build directory
-                         (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
+                     (lambda* (#:key tests? #:allow-other-keys)
+                       (when tests?
+                         ;; xfconfd requires a writable HOME
+                         (setenv "HOME" (getenv "TMPDIR"))
+                         ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+                         ;; many entries, maybe related to
+                         ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+                         (setenv "XDG_DATA_DIRS"
+                                 (string-append
+                                  #$output "/share:"
+                                  #$(this-package-native-input
+                                     "gsettings-desktop-schemas")
+                                  "/share"))
+                         ;; Don't fail on missing  '/etc/machine-id'.
+                         (setenv "DBUS_FATAL_WARNINGS" "0")
+                         (with-directory-excursion (string-append "../at-spi2-core-"
+                                                                  #$version "")
+                           (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+                           (substitute* "ci/run-tests.sh"
+                             (("ps auxwww") "")   ;avoid a dependency on procps
+                             (("meson test -C _build")
+                              "meson test -C ../build")) ;adjust build directory
+                           (invoke "dbus-run-session" "--" "ci/run-tests.sh"))))))
                 #~()))))
      (inputs
       (list bash-minimal libxml2))