diff mbox series

[bug#64201,v2,08/22] gnu: python-astropy: Update to 5.3.1.

Message ID bef9ad6b5c6d7bdedd14b44ffc510f0ed6be7669.1690410490.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Astronmy June updates. | expand

Commit Message

Sharlatan Hellseher July 26, 2023, 11:15 p.m. UTC
* gnu/packages/astronomy.scm (python-astropy): Update to 5.3.1.
[snippet]: Remove trailing #t. Prevent cfitsion from deletion.
[inputs]: Remove cfitsio.
---
 gnu/packages/astronomy.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c32f0fc539..a18de38fbd 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1262,13 +1262,13 @@  (define-public celestia-gtk
 (define-public python-astropy
   (package
     (name "python-astropy")
-    (version "5.2.2")
+    (version "5.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "astropy" version))
        (sha256
-        (base32 "170ddflli35mvhf6pla7aizfw8a7ckq66g1mi1br99dx2r3y7ag6"))
+        (base32 "0x4dh7wx9sn1gy6sl2d54zsd24cgfjwrlk6kfrwpzzrmbsv22lwv"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -1277,9 +1277,12 @@  (define-public python-astropy
              (for-each delete-file-recursively '("ply" "configobj")))
            ;; Remove cextern bundles. Check bundled versions against available
            ;; in Guix in the future update of astropy.
+           ;;
+           ;; cfitsio build is only available from non-publicly exposed
+           ;; bundled short version. See:
+           ;; https://github.com/astropy/astropy/pull/14311
            (with-directory-excursion "cextern"
-             (for-each delete-file-recursively '("cfitsio" "expat" "wcslib")))
-           #t))))
+             (for-each delete-file-recursively '("expat" "wcslib")))))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1346,7 +1349,7 @@  (define-public python-astropy
            python-skyfield
            python-timezonefinder))
     (inputs
-     (list cfitsio expat wcslib))
+     (list expat wcslib))
     (propagated-inputs
      (list python-configobj
            python-numpy