diff mbox series

[bug#70257] gnu: babl: Disable failing test on aarch64.

Message ID bee23551bc8c55d0980ad71449fa65bf9076af44.1712491898.git.roman@burningswell.com
State New
Headers show
Series [bug#70257] gnu: babl: Disable failing test on aarch64. | expand

Commit Message

Roman Scherer April 7, 2024, 12:17 p.m. UTC
* gnu/packages/gimp.scm (babl): Disable failing test on aarch64.

Change-Id: Icf2c2a9ea5986149902f741f96d1847d2403c1f4
---
 gnu/packages/gimp.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)


base-commit: 12f02c9bb87b8ea756e5c09806522e6df8b7e1ca
prerequisite-patch-id: 0250f6d992ee74e81797cb1266771a825226fa0b
prerequisite-patch-id: e03a4f63a64eda0c1f229e0b92d130a9beadefa5
prerequisite-patch-id: 09e6b4e8c70f5eb7996f78194c59245f38d3241b
prerequisite-patch-id: a12882ccf5bbef1edbd1110f128cd107f84a1377
prerequisite-patch-id: 2c83a46f3bcf9d3e153e2543fe9a57e5f33af286
prerequisite-patch-id: 3c1ca4618ff254748694208007768994f8f3f180
prerequisite-patch-id: c6c55378dfbf74f5862c5b5609fe7cc3dc4b52d7
prerequisite-patch-id: 6307af77f1d5ccaef3accfce06479f604cdfd260
prerequisite-patch-id: 1f06621d95d4b22729a1461bca01feeb0d491324
prerequisite-patch-id: 2b5ca4e046c327f00c14fb9a0b7a08b6e4014bcb
prerequisite-patch-id: 8d0e6879dd97e7a2183b915bbd1ca588d968aec0
prerequisite-patch-id: 7ebd64a45f6032d0fa2317d3b276cd93544ea187

Comments

Christopher Baines April 15, 2024, 9:02 a.m. UTC | #1
Roman Scherer <roman@burningswell.com> writes:

> * gnu/packages/gimp.scm (babl): Disable failing test on aarch64.
>
> Change-Id: Icf2c2a9ea5986149902f741f96d1847d2403c1f4
> ---
>  gnu/packages/gimp.scm | 12 ++++++++++--
>  1 file changed, 10 insertions(+), 2 deletions(-)

QA doesn't show any test failure being fixed.

Do you see this happening just some of the time, or only in some
situations? Also, can you include more information in the commit/a
comment about the specific failure?

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index b458a6397c..bcc18ad3cf 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -193,8 +193,16 @@  (define-public babl
                 "0x8lxvnhfpssj84x47y3y06vsvhd5afb9jknw38c8ymbxafzxpi6"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags
-       (list "-Dwith-docs=false")))
+     (list
+      #:configure-flags #~(list "-Dwith-docs=false")
+      #:phases
+      #~(modify-phases %standard-phases
+          #$@(if (target-aarch64?)
+                 #~((add-after 'unpack 'disable-failing-test
+                      (lambda _
+                        (substitute* "tests/meson.build"
+                          (("'float-to-8bit',") "")))))
+                 '()))))
     (native-inputs
      (list gobject-introspection pkg-config vala))
     (propagated-inputs