diff mbox series

[bug#44215,1/4] gnu: plasma-framework: Fix build errors in dependent packages.

Message ID bec802ee810d1bc3f9cdde958328a78f767390de.1603659776.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Some smaller KDE changes. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel Oct. 25, 2020, 9:09 p.m. UTC
Fix build errors in dependent packages if PREFIX is different from ECM's
PREFIX - which is the case in Guix.  See <https://bugs.kde.org/424483> for
details.

* gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch: New
  file.
* packages/kde-frameworks.scm (plasma-framework)[source]: Use this patch.
---
 gnu/packages/kde-frameworks.scm               |  3 ++-
 ...-framework-fix-KF5PlasmaMacros.cmake.patch | 25 +++++++++++++++++++
 2 files changed, 27 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch

Comments

Efraim Flashner Oct. 27, 2020, 8:53 a.m. UTC | #1
On Sun, Oct 25, 2020 at 10:09:19PM +0100, Hartmut Goebel wrote:
> Fix build errors in dependent packages if PREFIX is different from ECM's
> PREFIX - which is the case in Guix.  See <https://bugs.kde.org/424483> for
> details.
> 
> * gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch: New
>   file.
> * packages/kde-frameworks.scm (plasma-framework)[source]: Use this patch.
> ---
>  gnu/packages/kde-frameworks.scm               |  3 ++-
>  ...-framework-fix-KF5PlasmaMacros.cmake.patch | 25 +++++++++++++++++++
>  2 files changed, 27 insertions(+), 1 deletion(-)
> 

Don't forget to register the patch in gnu/local.mk
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c4479de995..cbcb8ff076 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3449,7 +3449,8 @@  setUrl, setUserAgent and call.")
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "06cxajsxj62g3c37ssrrcaxb9a12zbyp2kvrjqym329k5vd89272"))))
+                "06cxajsxj62g3c37ssrrcaxb9a12zbyp2kvrjqym329k5vd89272"))
+              (patches (search-patches "plasma-framework-fix-KF5PlasmaMacros.cmake.patch"))))
     (build-system cmake-build-system)
     (propagated-inputs
      `(("kpackage" ,kpackage)
diff --git a/gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch b/gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch
new file mode 100644
index 0000000000..bd55d512cf
--- /dev/null
+++ b/gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch
@@ -0,0 +1,25 @@ 
+From ff5ed26f21d304e867ab57781878069567deb23d Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Mon, 3 Aug 2020 19:49:58 +0000
+Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
+
+See <https://bugs.kde.org/424483> for details
+---
+ KF5PlasmaMacros.cmake | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/KF5PlasmaMacros.cmake b/KF5PlasmaMacros.cmake
+index 494b42d56..80b3fd8dd 100644
+--- a/KF5PlasmaMacros.cmake
++++ b/KF5PlasmaMacros.cmake
+@@ -1,6 +1,5 @@
+ 
+-find_package(ECM 1.6.0 CONFIG REQUIRED)
+-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
++include(KDEInstallDirs)
+ 
+ set(PLASMA_RELATIVE_DATA_INSTALL_DIR "plasma")
+ set(PLASMA_DATA_INSTALL_DIR "${KDE_INSTALL_DATADIR}/${PLASMA_RELATIVE_DATA_INSTALL_DIR}")
+-- 
+GitLab
+