From 3266b34db3b2fdc8d4c50f6585253130f5cead87 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 9 Jan 2020 11:13:33 -0500
Subject: [PATCH] gnu: Add gnome-user-share.
* gnu/packages/gnome.scm (gnome-user-share): New variable.
---
gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
@@ -246,6 +246,47 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-user-share
+ (package
+ (name "gnome-user-share")
+ (version "3.33.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0lf790pyamdyj7180ils8vizjl8brxcg7jsm1iavfp9ay4wa8mz7"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ `("-Dsystemd=false"
+ "-Dsystemduserunitdir=no"
+ ;; Enable nautilus extension for file sharing.
+ "-Dnautilus_extension=true")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gnome-bluetooth" ,gnome-bluetooth)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libnotify" ,libnotify)
+ ("nautilus" ,nautilus) ; For nautilus extension.
+ ("yelp-tools" ,yelp-tools)))
+ (synopsis "File sharing for GNOME desktop")
+ (description "GNOME User Share is a small package that binds together
+various free software projects to bring easy to use user-level file
+sharing to the masses.")
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-user-share")
+ (license license:gpl2)))
+
(define-public gnome-menus
(package
(name "gnome-menus")
--
2.24.1