diff mbox series

[bug#38906] gnu: Add gnome-user-share. (v2)

Message ID be84b81a1c9841b8349a22dc3e47e8d39b5a572a.camel@disroot.org
State Accepted
Headers show
Series [bug#38906] gnu: Add gnome-user-share. (v2) | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 9, 2020, 4:21 p.m. UTC
Hello Julien!

> Again, I don't really get what nautilus and gtk+ or yelp-tools are
> doing for the build. Are they used in the build? Aren't they runtime
> dependencies? Does the package work as expected?

I revised the patch with comments. They are needed for nautilus
extension.

> The description
> doesn't really make it clear: does this package provide a library or
> an executable? I think you can skip "free software" in the
> description,
> we wouldn't bind together non free software anyway :)

I will revising all gnome packages one-by-one soon. I am planning to do
the clean-up at that time. So I am willing to leave things as it is for
now. :-)

Please find the revised patch (v2) attached with this email.

Regards,
RG.

Comments

Danny Milosavljevic Jan. 12, 2020, 9:51 p.m. UTC | #1
>+         "-Dsystemduserunitdir=no"

That creates a directory "/no" and puts the systemd unit in there.
Raghav Gururajan Jan. 12, 2020, 9:58 p.m. UTC | #2
Hello Danny!

>> + "-Dsystemduserunitdir=no"
> 
> That creates a directory "/no" and puts the systemd unit in there.

OOPS! Please find the revised patch attached.

Thank you!

Regards,
RG.
Danny Milosavljevic Jan. 12, 2020, 10:10 p.m. UTC | #3
Pushed to guix master as commit b5f013929a776b6ae0611a1eeb19aa158412c65f
after moving gobject-introspection and yelp-tools to native-inputs.
Raghav Gururajan Jan. 12, 2020, 10:13 p.m. UTC | #4
Hello Danny!

> Pushed to guix master as commit b5f013929a776b6ae0611a1eeb19aa158412c65f
> after moving gobject-introspection and yelp-tools to native-inputs.

Thanks so much!

Regards,
RG.
diff mbox series

Patch

From 3266b34db3b2fdc8d4c50f6585253130f5cead87 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 9 Jan 2020 11:13:33 -0500
Subject: [PATCH] gnu: Add gnome-user-share.

* gnu/packages/gnome.scm (gnome-user-share): New variable.
---
 gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e71cc2fee2..2496cb8767 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,47 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gnome-user-share
+  (package
+   (name "gnome-user-share")
+   (version "3.33.1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "0lf790pyamdyj7180ils8vizjl8brxcg7jsm1iavfp9ay4wa8mz7"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:glib-or-gtk? #t
+      #:configure-flags
+       `("-Dsystemd=false"
+         "-Dsystemduserunitdir=no"
+         ;; Enable nautilus extension for file sharing.
+         "-Dnautilus_extension=true")))
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("gtk+:bin" ,gtk+ "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("glib" ,glib)
+      ("gnome-bluetooth" ,gnome-bluetooth)
+      ("gobject-introspection" ,gobject-introspection)
+      ("gtk+" ,gtk+)
+      ("libcanberra" ,libcanberra)
+      ("libnotify" ,libnotify)
+      ("nautilus" ,nautilus)      ; For nautilus extension.
+      ("yelp-tools" ,yelp-tools)))
+   (synopsis "File sharing for GNOME desktop")
+   (description "GNOME User Share is a small package that binds together
+various free software projects to bring easy to use user-level file
+sharing to the masses.")
+   (home-page "https://gitlab.gnome.org/GNOME/gnome-user-share")
+   (license license:gpl2)))
+
 (define-public gnome-menus
   (package
     (name "gnome-menus")
-- 
2.24.1