diff mbox series

[bug#73024,v2] gnu: Add fontopia.

Message ID be6552bd04f02b4b7bd2d923a0483ad137af4d7f.1725440552.git.atai@atai.org
State New
Headers show
Series [bug#73024,v2] gnu: Add fontopia. | expand

Commit Message

Andy Tai Sept. 4, 2024, 9:03 a.m. UTC
* gnu/packages/fontutils.scm (fontopia): New variable.

Change-Id: I8f9b51922af06f994955b755ec8345d42189cfd7
---
 gnu/packages/fontutils.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
prerequisite-patch-id: 6084d080fcb60fcbb2063ddf60036b4753c5dee3
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 00fb9c33ee..3a7bfa1aa0 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -62,6 +62,7 @@  (define-module (gnu packages fontutils)
   #:use-module (gnu packages java)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages man)
+  #:use-module (gnu packages mc)
   #:use-module (gnu packages ninja)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -2056,6 +2057,31 @@  (define-public libraqm
 can support most writing systems covered by Unicode.")
     (license license:expat)))
 
+
+(define-public fontopia
+  (package
+    (name "fontopia")
+    (version "2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/fontopia/fontopia-" version ".tar.gz"))
+       (sha256
+        (base32 "0wv7bd7gdm1ma4xgq9av73ic3xhpwyszj6g6c6311xjk26xm9ahd"))))
+    (build-system gnu-build-system)
+    (inputs (list gnudos))
+    (home-page "https://www.gnu.org/software/fontopia/")
+    (synopsis "A console font editor")
+    (description
+     "GNU Fontopia is an easy-to-use, text-based, console font editor.  It's used
+to edit the fonts that GNU/Linux uses to display text on text-based
+terminals.  Fontopia works on both PSF 1 & 2, BDF, Code Paged (CP) fonts, and
+Raw font files.  It provides a user-friendly, easy-to-use glyph editor and it
+can easily change font metrics (e.g. length, width, and height) and convert
+between different font formats.")
+    (license license:gpl3+)))
+
+
 (define-public lcdf-typetools
   (package
     (name "lcdf-typetools")