[bug#74601,1/3] gnu: Add python-clingexplaid.

Message ID be5daaf9cc11ca952517d482025419407553054b.1732873441.git.liliana.prikler@gmail.com
State New
Headers
Series Update clinguin to 2.1.1 |

Commit Message

Liliana Marie Prikler Nov. 29, 2024, 7:31 a.m. UTC
  * gnu/packages/potassco.scm (python-clingexplaid): New variable.
---
 gnu/packages/potassco.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
  

Patch

diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index ec990f1382..57caf6aabc 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -756,3 +756,36 @@  (define-public python-clintest
 outcome while solving to abort the search for solutions once the outcome is
 certain.")
     (license license:expat)))
+
+(define-public python-clingexplaid
+  (package
+    (name "python-clingexplaid")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/clingo-explaid")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1s80cs3clvz26r7cvjprlk6zip7yqswwhzzwmmrv5mf5p89ymrgm"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags #~(list "-k" "not test_main")
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'fix-pyproject-toml
+                          (lambda _
+                            (substitute* "pyproject.toml"
+                              (("dynamic = .*" all)
+                               (string-append "version = \""
+                                              #$version
+                                              "\"\n"))
+                              (("\"autoflake\",") "")))))))
+    (propagated-inputs (list python-clingo))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/potassco/clingo-explaid")
+    (synopsis "Develop explanation systems with Clingo")
+    (description "This package provides tools to develop explanation systems
+with clingo.  It allows extracting minimal unsatisfiable subsets and
+unsatisfiable constraints.")
+    (license license:expat)))