diff mbox series

[bug#70247,gnome-team,v2,2/4] gnu: gtk: Update to 4.14.2.

Message ID be50394128babb538b6684b6ce2f703634bafaca.1713553254.git.liliana.prikler@gmail.com
State New
Headers show
Series None | expand

Commit Message

Liliana Marie Prikler April 6, 2024, 7:34 a.m. UTC
* gnu/packages/gtk.scm (gtk): Update to 4.14.2.
[#:phases]<patch>: Disable new test failures.
[inputs]: Add shaderc.
---
 gnu/packages/gtk.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Maxim Cournoyer April 20, 2024, 4:19 p.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gtk.scm (gtk): Update to 4.14.2.
> [#:phases]<patch>: Disable new test failures.
> [inputs]: Add shaderc.
> ---
>  gnu/packages/gtk.scm | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 4fae0fd275..40b7200c57 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1119,7 +1119,7 @@ (define-public gtk+
>  (define-public gtk
>    (package
>      (name "gtk")
> -    (version "4.12.3")
> +    (version "4.14.2")
>      (source
>       (origin
>         (method url-fetch)
> @@ -1127,7 +1127,7 @@ (define-public gtk
>                             (version-major+minor version)  "/"
>                             name "-" version ".tar.xz"))
>         (sha256
> -        (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
> +        (base32 "0wp0w259rkwf6g8sk2b9jkms47vx5gp7mfs345grx9wq53plqq12"))
>         (patches
>          (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
>         (modules '((guix build utils)))))
> @@ -1199,7 +1199,13 @@ (define-public gtk
>                  ;; This test, 'gtk:tools / validate', started failing for
>                  ;; unknown reasons after updating mesa to 23.3.1 and xorgproto
>                  ;; to 2023.2.
> -                ((" 'validate',") ""))
> +                ((" 'validate',") "")
> +                ;; New failures with 4.14

nitpick: Please punctuate your standalone comments.  A link to the
reported upstream issues would be icing on the cake.

> +                (("'glyph-subpixel-position',") "")
> +                (("'subpixel-positioning',") "")
> +                (("'subpixel-positioning-hidpi-nogl-nocairo',") "")
> +                (("'text.*\\.node',") "")
> +                (("'text-mixed-color-colrv1',") ""))
>                (substitute* "testsuite/reftests/meson.build"
>                  (("[ \t]*'label-wrap-justify.ui',") "")
>                  ;; The inscription-markup.ui fails due to /etc/machine-id
> @@ -1267,6 +1273,7 @@ (define-public gtk
>             python-toml
>             python-typogrify
>             sassc                        ;for building themes
> +           shaderc
>             tzdata-for-tests
>             vala
>             xorg-server-for-tests))

Otherwise LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4fae0fd275..40b7200c57 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1119,7 +1119,7 @@  (define-public gtk+
 (define-public gtk
   (package
     (name "gtk")
-    (version "4.12.3")
+    (version "4.14.2")
     (source
      (origin
        (method url-fetch)
@@ -1127,7 +1127,7 @@  (define-public gtk
                            (version-major+minor version)  "/"
                            name "-" version ".tar.xz"))
        (sha256
-        (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
+        (base32 "0wp0w259rkwf6g8sk2b9jkms47vx5gp7mfs345grx9wq53plqq12"))
        (patches
         (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
        (modules '((guix build utils)))))
@@ -1199,7 +1199,13 @@  (define-public gtk
                 ;; This test, 'gtk:tools / validate', started failing for
                 ;; unknown reasons after updating mesa to 23.3.1 and xorgproto
                 ;; to 2023.2.
-                ((" 'validate',") ""))
+                ((" 'validate',") "")
+                ;; New failures with 4.14
+                (("'glyph-subpixel-position',") "")
+                (("'subpixel-positioning',") "")
+                (("'subpixel-positioning-hidpi-nogl-nocairo',") "")
+                (("'text.*\\.node',") "")
+                (("'text-mixed-color-colrv1',") ""))
               (substitute* "testsuite/reftests/meson.build"
                 (("[ \t]*'label-wrap-justify.ui',") "")
                 ;; The inscription-markup.ui fails due to /etc/machine-id
@@ -1267,6 +1273,7 @@  (define-public gtk
            python-toml
            python-typogrify
            sassc                        ;for building themes
+           shaderc
            tzdata-for-tests
            vala
            xorg-server-for-tests))