diff mbox series

[bug#67040] gnu: Add krename.

Message ID be46423e99071ca34fb62a9f37159230519d8077.1699615824.git.sughosha@disroot.org
State New
Headers show
Series [bug#67040] gnu: Add krename. | expand

Commit Message

Sughosha Nov. 10, 2023, 11:38 a.m. UTC
* gnu/packages/kde-utils.scm (krename): New variable.

Change-Id: I004f1fffa269f6182f89481970bd223aeec48bc4
---
 gnu/packages/kde-utils.scm | 63 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 63 insertions(+)


base-commit: 857c1996129e32f41cd7e1d4c04420b47563daed

Comments

Bruno Victal Nov. 18, 2023, 5:16 p.m. UTC | #1
Hi Sughosha,

On 2023-11-10 11:38, Sughosha wrote:
> +easily rename hundreds or even more files in one go.  The filenames can be
> +created by parts of the original filename, numbering the files or accessing
> +hundreds of information about the file, like creation date or Exif information
> +of an image.

I'd reword this to: “The filenames can be constructed using parts of the original
filename or information from the file metadata such as the creation date or Exif
information of an image.

> +Its features include:
> +
> +@itemize
> (…)
> +@item rename Mp3/Ogg Vorbis files based on their ID3 tags,

How about: “rename audio files (e.g. mp3, ogg) files based on their
metadata.”
Ogg files typically use “Vorbis comment” [1] for metadata, while
.mp3 files use IDv3 tags.

> +@item and many more...

I'd remove this from the @itemize list since it doesn't convey
anything worth noting.


[1]: <https://en.wikipedia.org/wiki/Vorbis_comment>
Sughosha Nov. 18, 2023, 9:37 p.m. UTC | #2
Hi Bruno,

Thanks for reviewing. These modifications are fine with me.


Regards,
Sughosha

On 18 November 2023 18:16:26 CET, Bruno Victal <mirai@makinata.eu> wrote:
>Hi Sughosha,
>
>On 2023-11-10 11:38, Sughosha wrote:
>> +easily rename hundreds or even more files in one go.  The filenames can be
>> +created by parts of the original filename, numbering the files or accessing
>> +hundreds of information about the file, like creation date or Exif information
>> +of an image.
>
>I'd reword this to: “The filenames can be constructed using parts of the original
>filename or information from the file metadata such as the creation date or Exif
>information of an image.
>
>> +Its features include:
>> +
>> +@itemize
>> (…)
>> +@item rename Mp3/Ogg Vorbis files based on their ID3 tags,
>
>How about: “rename audio files (e.g. mp3, ogg) files based on their
>metadata.”
>Ogg files typically use “Vorbis comment” [1] for metadata, while
>.mp3 files use IDv3 tags.
>
>> +@item and many more...
>
>I'd remove this from the @itemize list since it doesn't convey
>anything worth noting.
>
>
>[1]: <https://en.wikipedia.org/wiki/Vorbis_comment>
>
>-- 
>Furthermore, I consider that nonfree software must be eradicated.
>
>Cheers,
>Bruno.
>
diff mbox series

Patch

diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 4e665da599..719139a320 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -35,11 +35,15 @@  (define-module (gnu packages kde-utils)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages cups)
+  #:use-module (gnu packages fontutils)
   #:use-module (gnu packages glib) ; dbus for tests
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gstreamer)
+  #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages mp3)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages kde)
   #:use-module (gnu packages kde-frameworks)
@@ -887,6 +891,65 @@  (define-public kmouth
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
 
+(define-public krename
+  (package
+    (name "krename")
+    (version "5.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/krename/" version
+                                  "/src/krename-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1v935xlsy7lyp1fgmy5ad3x5i9d8rigwanpmsx6xpxnrvnkn0g5j"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules pkg-config))
+    (inputs
+     (list exiv2
+           freetype
+           karchive
+           kcompletion
+           kconfig
+           kcoreaddons
+           kcrash
+           ki18n
+           kiconthemes
+           kio
+           kitemviews
+           kjobwidgets
+           kjs
+           kservice
+           kwidgetsaddons
+           kxmlgui
+           podofo
+           taglib))
+    (home-page "https://userbase.kde.org/KRename")
+    (synopsis "Utility to handle specialized file renames")
+    (description "KRename is a batch file renamer by KDE.  It allows you to
+easily rename hundreds or even more files in one go.  The filenames can be
+created by parts of the original filename, numbering the files or accessing
+hundreds of information about the file, like creation date or Exif information
+of an image.
+
+Its features include:
+
+@itemize
+@item renaming a list of files based on a set of expressions,
+@item copying/moving a list of files to another directory,
+@item converting filenames to upper/lower case,
+@item adding numbers to filenames,
+@item finding and replacing parts of the filename,
+@item rename Mp3/Ogg Vorbis files based on their ID3 tags,
+@item setting access and modification dates, permissions and file ownership,
+@item a plug-in API which allows you to extend KRename's features,
+@item renaming directories recursively,
+@item support for KFilePlugins,
+@item creating undo file
+@item and many more...
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public kronometer
   (package
     (name "kronometer")