[bug#75665] gnu: Add mbpoll.
Commit Message
* gnu/packages/engineering.scm (mbpoll): New variable.
Change-Id: I356425b47ae4a5201465c9f1e0244602a1cf9dc2
---
gnu/packages/engineering.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)
base-commit: dc50af1ca527af0ef03dae4eef3757272428b1a7
Comments
Merged to the "master" branch as
9366217997d759a4150cf5e44d83b947ac2028ab
- avp
@@ -33,7 +33,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Konstantinos Agiannis <agiannis.kon@gmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2022, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022, 2024, 2025 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Theofilos Pechlivanis <theofilos.pechlivanis@gmail.com>
@@ -217,6 +217,33 @@ (define-public librecad
plans and designs.")
(license license:gpl2)))
+(define-public mbpoll
+ (package
+ (name "mbpoll")
+ (version "1.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/epsilonrt/mbpoll")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h5qsgy5hkrq92nxfkl564w21g5vp9nnch04fdqij06ckvzf7vdc"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ;no tests
+ (native-inputs (list pkg-config))
+ (inputs (list libmodbus))
+ (home-page "https://github.com/epsilonrt/mbpoll")
+ (synopsis
+ "Command line utility to communicate with ModBus slave (RTU or TCP)")
+ (description
+ "@code{mbpoll} is a command line utility to communicate with
+@url{https://en.wikipedia.org/wiki/Modbus, ModBus} slave (RTU or TCP).")
+ (license license:gpl3)))
+
(define-public geda-gaf
(package
(name "geda-gaf")