diff mbox series

[bug#57078] gnu: torsocks: Update to 2.4.0

Message ID be0b7ec048c7fc93c477f660e8e20ecd70feaeaf.1660055920.git.jnewsome@torproject.org
State Accepted
Headers show
Series [bug#57078] gnu: torsocks: Update to 2.4.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jim Newsome Aug. 9, 2022, 2:38 p.m. UTC
From: Jim Newsome <jnewsome@torproject.org>

* gnu/packages/tor.scm (torsocks): Update to 2.4.0.
[native-inputs]: Set to autoconf, automake, libtool. torsocks releases
no longer pre-run autogen.sh.
[synopsis, description]: Clarify that applications do not need to be
socks-aware to be used with torsocks.
---
 gnu/packages/tor.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)


base-commit: 515288874ff12c00ca8d1d22a94ef4b4903fec76

Comments

Mathieu Othacehe Aug. 15, 2022, 9:22 a.m. UTC | #1
Hello,

> * gnu/packages/tor.scm (torsocks): Update to 2.4.0.
> [native-inputs]: Set to autoconf, automake, libtool. torsocks releases
> no longer pre-run autogen.sh.
> [synopsis, description]: Clarify that applications do not need to be
> socks-aware to be used with torsocks.

I added your copyright and wrapped the description before pushing.

Thanks,

Mathieu
Jim Newsome Aug. 15, 2022, 2:32 p.m. UTC | #2
Great, thanks!

On 8/15/22 04:22, Mathieu Othacehe wrote:
> 
> Hello,
> 
>> * gnu/packages/tor.scm (torsocks): Update to 2.4.0.
>> [native-inputs]: Set to autoconf, automake, libtool. torsocks releases
>> no longer pre-run autogen.sh.
>> [synopsis, description]: Clarify that applications do not need to be
>> socks-aware to be used with torsocks.
> 
> I added your copyright and wrapped the description before pushing.
> 
> Thanks,
> 
> Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 613575ae0e..fb913595ea 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -160,17 +160,19 @@  (define-public tor-client
 (define-public torsocks
   (package
     (name "torsocks")
-    (version "2.3.0")
+    (version "2.4.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://people.torproject.org/~dgoulet/"
-                                  "torsocks/torsocks-" version ".tar.xz"))
+              (uri (string-append "https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v"
+                                   version "/torsocks-v" version ".tar.bz2"))
               (sha256
                (base32
-                "08inrkap29gikb6sdmb58z43hw4abwrfw7ny40c4xzdkss0vkwdr"))))
+                "1a7k3njdhp7dz603knhisna1zvxw35j3g213p6dvczv9bcjy7cjl"))))
     (build-system gnu-build-system)
     (inputs
      (list libcap))
+    (native-inputs
+     (list autoconf automake libtool))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-after 'build 'absolutize
@@ -180,9 +182,9 @@  (define-public torsocks
                          (string-append "getcap=" (which "getcap") "\n")))
                       #t)))))
     (home-page "https://www.torproject.org/")
-    (synopsis "Use socks-friendly applications with Tor")
+    (synopsis "Transparently route an application's traffic through Tor.")
     (description
-     "Torsocks allows you to use most socks-friendly applications in a safe
+     "Torsocks allows you to use most applications in a safe
 way with Tor.  It ensures that DNS requests are handled safely and explicitly
 rejects UDP traffic from the application you're using.")