[bug#76333] gnu: emacs-magit-stgit: Update to 3.1.0.

Message ID be0245d12e440f4a0a2a1091a65ca7062b1dace1.1739701737.git.csantosb@inventati.org
State New
Headers
Series [bug#76333] gnu: emacs-magit-stgit: Update to 3.1.0. |

Commit Message

Cayetano Santos Feb. 16, 2025, 10:28 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-magit-stgit): Update to 3.1.0.

Change-Id: I20a45930c783edb400174ef53d067c0ce0ba9154
---
 gnu/packages/emacs-xyz.scm | 41 +++++++++++++++++++-------------------
 1 file changed, 20 insertions(+), 21 deletions(-)


base-commit: dd7a377c38c2a3e0cb80b0e45b32dfbe4577a739
--
2.48.1
  

Comments

Ian Eure Feb. 17, 2025, 5:44 p.m. UTC | #1
Hi Cayetano,

Pushed as 4e1e9f4cc2 with a small fix to the release tag; upstream 
doesn’t have the "v" prefix specified in the commit field.

Also noted that this patch the package build, which was broken in 
master, thank you!

  -- Ian
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fd1e2a5887..53e838335e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1909,32 +1909,31 @@  (define-public emacs-magit
     (license license:gpl3+)))
 
 (define-public emacs-magit-stgit
-  (let ((commit "51168b7438dfb5ca6b9239b8564397cc0cc6e798")
-        (revision "0"))
-    (package
-      (name "emacs-magit-stgit")
-      (version (git-version "2.2.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/stacked-git/magit-stgit.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1z2dhc1m510iyrks5lxp3jlqg4n7qwwirbmxg4c4ll0xngfhnalc"))))
-      (build-system emacs-build-system)
-      (propagated-inputs (list emacs-magit emacs-transient))
-      (home-page "https://github.com/stacked-git/magit-stgit")
-      (synopsis "StGit extension for Magit")
-      (description
-       "This package provides basic support for @code{stgit} in
+  (package
+    (name "emacs-magit-stgit")
+    (version "3.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/stacked-git/magit-stgit.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1z2dhc1m510iyrks5lxp3jlqg4n7qwwirbmxg4c4ll0xngfhnalc"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-magit emacs-transient emacs-llama
+                             emacs-dash))
+    (home-page "https://github.com/stacked-git/magit-stgit")
+    (synopsis "StGit extension for Magit")
+    (description
+     "This package provides basic support for @code{stgit} in
 @code{emacs-magit}.  When @code{magit-stgit-mode} is turned on, the
 current patch series is displayed in the status buffer.  While point is on a
 patch the changes it introduces can be shown using @code{RET}, it can be selected
 as the current patch using @code{a}, and it can be discarded using @code{k}.  Other
 @code{StGit} commands are available from the @code{StGit} transient on @code{/}.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-magit-svn
   (package