diff mbox series

[bug#64841] gnu: python-shiboken-6: Remove inherited workaround.

Message ID bdf8a8591e97f061da0b27694700648813349c20.1690244119.git.hako@ultrarare.space
State New
Headers show
Series [bug#64841] gnu: python-shiboken-6: Remove inherited workaround. | expand

Commit Message

Hilton Chain July 25, 2023, 12:16 a.m. UTC
Fixes: <https://issues.guix.gnu.org/64803>.

The importlib workaround inherited from python-shiboken-2 is not required for
building python-pyside-6, and will cause a build issue on the identation.

* gnu/packages/qt.scm (python-shiboken-6)[arguments]<#:phases>: Delete
'workaround-importlib-error.

Reported-by: Formbi <formbi@protonmail.com>
---
 gnu/packages/qt.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: 76e041f9eef85bb039c5251d3350c62ee2066883

Comments

Andreas Enge July 26, 2023, 12:42 p.m. UTC | #1
Hello,

Am Tue, Jul 25, 2023 at 08:16:11AM +0800 schrieb Hilton Chain:
> Fixes: <https://issues.guix.gnu.org/64803>.

thanks for the report and the fix! I confirm it makes the package itself and
its unique dependent package python-pyside-6 build.

Closing the bug.

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a79338f84e..e8654eee44 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4005,6 +4005,7 @@  (define-public python-shiboken-6
      (substitute-keyword-arguments (package-arguments python-shiboken-2)
        ((#:phases p)
         #~(modify-phases #$p
+            (delete 'workaround-importlib-error)
             (replace 'use-shiboken-dir-only
               (lambda _ (chdir "sources/shiboken6")))))
        ((#:configure-flags flags)