diff mbox series

[bug#62758] gnu: autogen: Fix build on i686.

Message ID bdef0240f232f5612ad84433a11c7a4ad0a31bda.1681151588.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#62758] gnu: autogen: Fix build on i686. | expand

Commit Message

Kaelyn Takata April 10, 2023, 6:33 p.m. UTC
* gnu/packages/autogen.scm (autogen): Fix build on i686.
---
 gnu/packages/autogen.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)


base-commit: ae5d3525348de562b84fc9faccf09fd6e06ab3df
--
2.39.2

Comments

Kaelyn Takata April 10, 2023, 6:57 p.m. UTC | #1
Sorry, I messed up a little bit on the subject line of this patch. It is for core-updates, but forgot to update the subject prefix.
diff mbox series

Patch

diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index 9751e11a64..f9575b0dc9 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,10 +44,15 @@  (define-public autogen
         (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))
        (modules '((guix build utils)))
        (snippet
-        ;; Address '-Werror=format-overflow' error.
-        '(substitute* "getdefs/getdefs.c"
-           (("def_bf\\[[[:space:]]*MAXNAMELEN[[:space:]]*\\]")
-            "def_bf[MAXNAMELEN + 10]")))))
+        '(begin
+           ;; Address '-Werror=format-overflow' error.
+           (substitute* "getdefs/getdefs.c"
+             (("def_bf\\[[[:space:]]*MAXNAMELEN[[:space:]]*\\]")
+              "def_bf[MAXNAMELEN + 10]"))
+           ;; Address '-Werror=format-truncation' error on i686.
+           (substitute* "autoopts/usage.c"
+             (("vfmt\\[sizeof\\(vfmtfmt\\)\\]")
+              "vfmt[sizeof(vfmtfmt) + 6]"))))))
     (build-system gnu-build-system)
     (native-inputs (list pkg-config which))
     (inputs (list guile-3.0 perl))          ; for doc generator mdoc