diff mbox series

[bug#63566,v1] gnu: add tcptrack

Message ID bdc9794ec379bee1c8f695dffeba60c2e3032c6d.1687378487.git.jakob.kirsch@web.de
State New
Headers show
Series [bug#63566,v1] gnu: add tcptrack | expand

Commit Message

Jakob Kirsch June 21, 2023, 8:14 p.m. UTC
* gnu/packages/admin.scm (tcptrack): New variable
---
 gnu/packages/admin.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: dcca13ed7340f17a33a4c0907c13b64d5da66a8e
--
2.39.3

Comments

Maxim Cournoyer Sept. 1, 2023, 2:38 p.m. UTC | #1
Hi,

Jakob Kirsch <jakob.kirsch@web.de> writes:

> * gnu/packages/admin.scm (tcptrack): New variable
> ---
>  gnu/packages/admin.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 529a477ed0..3dd8b25836 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -4256,6 +4256,29 @@ (define-public thermald
>      (supported-systems '("i686-linux" "x86_64-linux"))
>      (license license:gpl2)))
>
> +(define-public tcptrack
> +  (package
> +    (name "tcptrack")
> +    (version "1.4.3")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/bchretien/tcptrack")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
> +    (build-system gnu-build-system)
> +    (inputs (list libpcap ncurses))
> +    (synopsis "Display information about TCP connections")
> +    (description
> +     "Tcptrack is a sniffer which displays information about TCP connections
> +it sees on a network interface.  This is a fork of Steve Benson’s tcptrack.")
> +    (home-page "https://github.com/bchretien/tcptrack")
> +    ; the COPYING file states the following license but the tcptrack.spec states just 'GPL'
> +    (license license:lgpl2.1)))

I've made the following small changes:

--8<---------------cut here---------------start------------->8---
modified   gnu/packages/admin.scm
@@ -4291,13 +4291,12 @@ (define-public tcptrack
                 "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
     (build-system gnu-build-system)
     (inputs (list libpcap ncurses))
-    (synopsis "Display information about TCP connections")
+    (synopsis "TCP connections sniffer")
     (description
      "Tcptrack is a sniffer which displays information about TCP connections
 it sees on a network interface.  This is a fork of Steve Benson’s tcptrack.")
     (home-page "https://github.com/bchretien/tcptrack")
-    ; the COPYING file states the following license but the tcptrack.spec states just 'GPL'
-    (license license:lgpl2.1)))
+    (license license:lgpl2.1+)))
 
 (define-public masscan
   (package
--8<---------------cut here---------------end--------------->8---

Fixing the license (note the + which means 'or later').  Conventionally
the synopsis is worded to describe what it *is* rather than what it
does (the later is kept for the description).

I've now installed the change, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 529a477ed0..3dd8b25836 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4256,6 +4256,29 @@  (define-public thermald
     (supported-systems '("i686-linux" "x86_64-linux"))
     (license license:gpl2)))

+(define-public tcptrack
+  (package
+    (name "tcptrack")
+    (version "1.4.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bchretien/tcptrack")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
+    (build-system gnu-build-system)
+    (inputs (list libpcap ncurses))
+    (synopsis "Display information about TCP connections")
+    (description
+     "Tcptrack is a sniffer which displays information about TCP connections
+it sees on a network interface.  This is a fork of Steve Benson’s tcptrack.")
+    (home-page "https://github.com/bchretien/tcptrack")
+    ; the COPYING file states the following license but the tcptrack.spec states just 'GPL'
+    (license license:lgpl2.1)))
+
 (define-public masscan
   (package
     (name "masscan")