[bug#78422,electronics-team] gnu: Add python-apycula.
Commit Message
* gnu/packages/electronics.scm (python-apycula): New variable.
Change-Id: I8e65416c1a555be189e9b8433d1ec7165aee16e9
---
gnu/packages/electronics.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
base-commit: 5f5d84beccc180f1b51474c0e47eb6e0d0c9175f
Comments
On Wed, May 14, 2025 at 12:30:07PM +0200, Cayetano Santos wrote:
> + #:tests? #f ;requires network
This is a pity - any chance we could disable just a single test that
needs networking or do all tests need it?
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'sanity-check-fix
> + (lambda _
> + (substitute* "setup.py"
> + (("'gowin_bba")
> + "# 'gowin_bbva")))))))
You (probably) could just substitute with an empty string "" (aka
deleting) instead of commenting it out. But it doesn't really matter.
Maybe a comment on why this fixes anything could be a nice pointer for
future us on why it is/was necessary?
Apart from these questions this LGTM.
If it builds, works as expected and the linter is happy this could be
merged IMO.
Thanks for your time and effort!
gabber
@@ -563,6 +563,39 @@ (define-public pulseview
for sigrok.")
(license license:gpl3+)))
+(define-public python-apycula
+ (package
+ (name "python-apycula")
+ (version "0.18")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/YosysHQ/apicula/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r1qx2q5dyjj3085g4ql41b21108m0s3wb7ylsy7xllvw527798l"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ;requires network
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'sanity-check-fix
+ (lambda _
+ (substitute* "setup.py"
+ (("'gowin_bba")
+ "# 'gowin_bbva")))))))
+ (propagated-inputs (list python-crc))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/YosysHQ/apicula/")
+ (synopsis "Gowin FPGA bitstream format")
+ (description
+ "The project Apycula provides tools to support development and
+generating bitstreams with Gowin FPGAs.")
+ (license license:expat)))
+
(define-public python-edalize
(package
(name "python-edalize")