diff mbox series

[bug#65715,v2] gnu: pantheon-calculator: Update to 2.0.2.

Message ID bda29a86590ccf19f27cb487ab3fef8ded18d29b.1693745248.git.altadil@protonmail.com
State New
Headers show
Series [bug#65715,v2] gnu: pantheon-calculator: Update to 2.0.2. | expand

Commit Message

altadil Sept. 3, 2023, 12:54 p.m. UTC
* gnu/packages/pantheon (pantheon-calculator): Update to 2.0.2.
---
This patch must be applied after the one for granite
(https://debbugs.gnu.org/cgi/bugreport.cgi?bug=65458).
This version of calculator cannot build with the current version of
granite but I tested locally that it does build
(on x86_64, i686 and aarch64) once granite is up-to-date.
 gnu/packages/pantheon.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)


base-commit: 52af65cf661603b4f6bdc39c2565105577003992
prerequisite-patch-id: 36af07118dd514ad62778401445fbd484b27ac86

Comments

Maxim Cournoyer Sept. 6, 2023, 3:06 a.m. UTC | #1
Hi,

altadil <Altadil@protonmail.com> writes:

> * gnu/packages/pantheon (pantheon-calculator): Update to 2.0.2.

I've completed the ChangeLog commit message for you like:

--8<---------------cut here---------------start------------->8---
    gnu: pantheon-calculator: Update to 2.0.2.
    
    * gnu/packages/pantheon (pantheon-calculator): Update to 2.0.2.
    [inputs]: Replace gtk+ with gtk.
    [native-inputs]: Remove labels.
--8<---------------cut here---------------end--------------->8---

and installed the commit as 88abdb43d667e2bd2d81c7ae34b7242725c3ff5d.

Closing!
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index c5cbde24c0..8bd15622f3 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -74,7 +74,7 @@  (define-public granite
 (define-public pantheon-calculator
   (package
     (name "pantheon-calculator")
-    (version "1.7.2")
+    (version "2.0.2")
     (source
      (origin
        (method git-fetch)
@@ -84,7 +84,7 @@  (define-public pantheon-calculator
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "11rwwi6nlhwpcm29dn2mbz0239nfjdwlqlqbchm0j9sr1ypifk2k"))))
+         "1w59sgznzybawhz411avqayws8jq0471n6hwhkplvcz7inxlzdrw"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -96,15 +96,15 @@  (define-public pantheon-calculator
     (inputs
       (list granite
             glib
-            gtk+
+            gtk
             libgee
             libhandy))
     (native-inputs
-     `(("cmake" ,cmake)
-       ("glib:bin" ,glib "bin") ; for glib-compile-schemas
-       ("gettext" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)
-       ("vala" ,vala)))
+      (list cmake
+            `(,glib "bin") ; for glib-compile-schemas
+            gettext-minimal
+            pkg-config
+            vala))
     (home-page "https://github.com/elementary/calculator")
     (synopsis "Desktop calculator")
     (description "Calculator is an application for performing simple