[bug#67755,v5,6/9] gnu: Add nativefiledialog-extended.
Commit Message
From: Sergio Pastor Pérez <sergio.pastorperez@outlook.es>
* gnu/packages/cpp.scm (nativefiledialog-extended): New variable.
Change-Id: I89ed4554db3ec8075bbb7d50bbfb4b99cae81a27
---
gnu/packages/cpp.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -3691,6 +3691,31 @@ (define-public mpark-variant
based on the implementation of std::variant in libc++.")
(license license:boost1.0)))
+(define-public nativefiledialog-extended
+ (package
+ (name "nativefiledialog-extended")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/btzy/nativefiledialog-extended")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15l0jy3v4p6rgg9dk8zr80lqp51s32ii62cm4s90400ragdgh10v"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ (native-inputs (list pkg-config))
+ (inputs (list gtk+))
+ (home-page "https://github.com/btzy/nativefiledialog-extended")
+ (synopsis "Native file dialog library with C and C++ bindings")
+ (description
+ "Cross platform (Windows, Mac, Linux) native file dialog
+library with C and C++ bindings, based on mlabbe/nativefiledialog.")
+ (license license:zlib)))
+
(define-public tsl-hopscotch-map
(package
(name "tsl-hopscotch-map")