[bug#77902,v2,science-team,4/7] gnu: python-vtraag-louvain: Deprecate.

Message ID bcff154e0baad9e3bcf4b27ec5ebaf6b91417418.1746463068.git.code@greghogan.com
State New
Headers
Series Update SuiteSparse. |

Commit Message

Greg Hogan May 5, 2025, 4:43 p.m. UTC
  * gnu/packages/graph.scm (python-vtraag-louvain): Deprecate with
replacement python-louvain-igraph.

Change-Id: I4e8b938a0a7ffb1932209bfff97a84b075aabb0e
---
 gnu/packages/graph.scm | 39 +++------------------------------------
 1 file changed, 3 insertions(+), 36 deletions(-)
  

Patch

diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 6a0b16d79a..65aeb79830 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -395,42 +395,6 @@  (define-public python-louvain
 algorithm for community detection in large networks.")
     (license license:bsd-3)))
 
-(define-public python-vtraag-louvain
-  (package
-    (name "python-vtraag-louvain")
-    (version "0.8.0")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "louvain" version))
-              (sha256
-               (base32
-                "16l2zi4jwc3vpvpnz32jv7xy0g5087dp9y57wxplj1xa9r312x0i"))))
-    (build-system pyproject-build-system)
-    (arguments
-     (list
-      #:phases
-      '(modify-phases %standard-phases
-         (add-after 'unpack 'do-not-use-bundled-igraph
-           (lambda _
-             (substitute* "setup.py"
-               (("self.external = False")
-                "self.external = True")
-               (("self.use_pkgconfig = False")
-                "self.use_pkgconfig = True")))))))
-    (inputs (list igraph))
-    (propagated-inputs (list python-igraph python-setuptools))
-    (native-inputs
-     (list pkg-config
-           python-ddt
-           python-setuptools-scm
-           python-wheel))
-    (home-page "https://github.com/vtraag/louvain")
-    (synopsis "Community detection in large networks")
-    (description
-     "Louvain is a general algorithm for methods of community detection in
-large networks.")
-    (license license:gpl3+)))
-
 (define-public python-graphtools
   (package
     (name "python-graphtools")
@@ -535,6 +499,9 @@  (define-public python-louvain-igraph
 algorithm for a number of different methods.")
     (license license:gpl3+)))
 
+(define-public python-vtraag-louvain
+  (deprecated-package "python-vtraag-louvain" python-louvain-igraph))
+
 (define-public python-pygsp
   (package
     (name "python-pygsp")