diff mbox series

[bug#55377] gnu: recutils: Make it cross-compilable.

Message ID bccc99666315ff908c93a4cedb128002bfcec9cb.camel@telenet.be
State New
Headers show
Series [bug#55377] gnu: recutils: Make it cross-compilable. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M May 11, 2022, 9:25 p.m. UTC
TBD:

  * [ ] Commit message
  * [ ] Testing beyond ‘it builds’
  * [ ] Proper usage of "git format-patch"
  * [ ] 'guix style'
  * [ ] "guix refresh --list-dependents" and such

Just sending it now such that it doesn't disappear, intend to make it a
proper patch submission later ...

               ("libgcrypt" ,libgcrypt)
               ("libuuid" ,util-linux "lib")))
     (synopsis "Manipulate plain text files as databases")

Comments

M May 12, 2022, 7:07 a.m. UTC | #1
tags 55377 + moreinfo
thanks

Maxime Devos schreef op wo 11-05-2022 om 23:25 [+0200]:
> TBD:
> 
>   * [ ] Commit message
>   * [ ] Testing beyond ‘it builds’
>   * [ ] Proper usage of "git format-patch"
>   * [ ] 'guix style'
>   * [ ] "guix refresh --list-dependents" and such

Needs a rebase because of
<https://git.savannah.gnu.org/cgit/guix.git/commit/?id=b4c9a3d23b06d9441e96938b45fbf6669685955d>.
Still, a bash:include in native-inputs doesn't seem correct to me even
if it happens to work here -- e.g., what if the include headers are
architecture-dependent?

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4472677ab3..ffadb1312b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1569,18 +1569,17 @@  (define-public recutils
                
"14xiln4immfsw8isnvwvq0h23f6z0wilpgsc4qzabnrzb5lsx3nz"))))
     (build-system gnu-build-system)
 
-    (arguments '(#:configure-flags
-                 (list (string-append "--with-bash-headers="
-                                      (assoc-ref %build-inputs
"bash:include")
-                                      "/include/bash"))))
-
+    (arguments
+      (list #:configure-flags
+            #~(list (string-append "--with-bash-headers="
+                                    (search-input-directory %build-
inputs "/include/bash")))))
     (native-inputs `(("bc" ,bc)
-                     ("bash:include" ,bash "include")
                      ("check" ,check-0.14)
                      ("pkg-config" ,pkg-config)))
 
     ;; TODO: Add more optional inputs.
-    (inputs `(("curl" ,curl)
+    (inputs `(("bash:include" ,bash "include")
+              ("curl" ,curl)