diff mbox series

[bug#72325] gnu: sbcl: Fix startup error on i686-linux.

Message ID bc7a69bf61485bf3000a30ff8bb646b708346c8c.1722106685.git.dariqq@posteo.net
State New
Headers show
Series [bug#72325] gnu: sbcl: Fix startup error on i686-linux. | expand

Commit Message

Dariqq July 27, 2024, 6:58 p.m. UTC
Fixes https://issues.guix.gnu.org/69106.

* gnu/packages/lisp.scm (sbcl)
[#phases]: Invoke make.sh with smaller dynamic-space-size when building for x86-32.

Change-Id: I08e8d2304d883973ab9a1b6a900ea9ee1679fac5
---

Played around with a 32 bit machine today and encountered this issue which has already been reported. As the check for the target happens inside a gexp this only causes rebuilds for i686-linux and not all architectures.

 gnu/packages/lisp.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: c6ff1d6ff761af0bd9bac5403fd834f04a14a192

Comments

Guillaume Le Vaillant Aug. 22, 2024, 8:02 a.m. UTC | #1
Patch applied as 803f9d3038d3c3048079c63d51b7b40bff09f17a.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 97f7dd357b..16ce1f25b6 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -1425,8 +1425,9 @@  (define-public sbcl
                                          `("clisp")))
                      (string-append "--prefix="
                                     (assoc-ref outputs "out"))
-                     ,@(if (target-ppc32?)
-                         ;; 3072 is too much for this architecture.
+                     ,@(if (or (target-ppc32?)
+                               (target-x86-32?))
+                         ;; 3072 is too much for these architecture.
                          `("--dynamic-space-size=2048")
                          `("--dynamic-space-size=3072"))
                      "--with-sb-core-compression"