diff mbox series

[bug#69360] gnu: b4: Update to 0.13.0.

Message ID bbce098dcccb3c2e6de0909692ad99db6dc0a75c.1708796076.git.hako@ultrarare.space
State New
Headers show
Series [bug#69360] gnu: b4: Update to 0.13.0. | expand

Commit Message

Hilton Chain Feb. 24, 2024, 5:35 p.m. UTC
* gnu/packages/version-control.scm (b4): Update to 0.13.0.
[source]: Switch to git source for tests.
[build-system]: Switch to pyproject-build-system.
[arguments]<#:tests?>: Enable.
[propagated-inputs]: Move patatt to…
[inputs]: …here
Add git-filter-repo.
[native-inputs]: Add python-pytest.

Change-Id: I2b24db0f72fc180ea6b12a5829d79ad0be7719a5
---
 gnu/packages/version-control.scm | 28 +++++++++++++++++++---------
 1 file changed, 19 insertions(+), 9 deletions(-)


base-commit: 313458c58c3fd89705081e1721e7c6fe7818d813
prerequisite-patch-id: c615f2b08070db6cbe847a2bdd5b7c0aae79789b
prerequisite-patch-id: fd7da036342f36a8c698f5c8975f9e48d3ade435
prerequisite-patch-id: a2c81c14423bb9858f33d7d26976e8eea61982b7
prerequisite-patch-id: e30fd25b1dc4aaaff76474153836cd48e8565eb9
prerequisite-patch-id: 1d070b26dc64ee2ec95f14c4f5fc23419f766810
prerequisite-patch-id: 03de992f0312d5f0ee3368ebc3c1fad7c955d095
prerequisite-patch-id: b330efe2b0713e30b766c3b84643df67eb1eae5d

Comments

Andreas Enge Feb. 29, 2024, 10:58 a.m. UTC | #1
Hello Hilton,

the package looks good to me and passes QA, so I would suggest to push it.

A tiny detail in the commit message:
Each line should end with a "." and there is no need to add a new line
in [inputs].

Andreas
Hilton Chain March 1, 2024, 6:21 a.m. UTC | #2
Hi Andreas,

On Thu, 29 Feb 2024 18:58:21 +0800,
Andreas Enge wrote:
>
> Hello Hilton,
>
> the package looks good to me and passes QA, so I would suggest to push it.
>
> A tiny detail in the commit message:
> Each line should end with a "." and there is no need to add a new line
> in [inputs].

Thank you!  Adjusted and applied as 2d861fd8f0cbe5e615f296b9439103cfb395b7db.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index af237ab4ee..5665e1f794 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -83,6 +83,7 @@  (define-module (gnu packages version-control)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
   #:use-module (guix build-system qt)
   #:use-module (guix build-system trivial)
@@ -2914,16 +2915,20 @@  (define-public patatt
 (define-public b4
   (package
     (name "b4")
-    (version "0.12.3")
+    (version "0.13.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "b4" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.kernel.org/pub/scm/utils/b4/b4.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0qpa0ahw1d86mdgs09ykq5pd0lm8083ds6j0knalw757yh31akmn"))))
-    (build-system python-build-system)
+        (base32
+         "1dijszinn00r6d0lxii3jz36h2c23zavbgz1m8finp5v6kaiafcg"))))
+    (build-system pyproject-build-system)
     (arguments
-     (list #:tests? #f                  ;no tests
+     (list #:tests? (not (%current-target-system)) ;git path hardcoded.
            #:phases
            #~(modify-phases %standard-phases
                ;; XXX: dnspython attempts to read /etc/resolv.conf when loading
@@ -2938,9 +2943,14 @@  (define-public b4
                       (string-append
                        "['" (search-input-file inputs "bin/git") "'"))))))))
     (inputs
-     (list git-minimal python-dkimpy python-dnspython python-requests))
-    (propagated-inputs
-     (list patatt))
+     (list git-filter-repo
+           git-minimal
+           patatt
+           python-dkimpy
+           python-dnspython
+           python-requests))
+    (native-inputs
+     (list python-pytest))
     (home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")
     (synopsis "Tool for working with patches in public-inbox archives")
     (description