diff mbox series

[bug#65743,v2,2/2] gnu: python-qtsass: Update to 0.4.0, fix build.

Message ID bba774d581b9485bb6e071a81452fdadc0dab444.1693952609.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#65743,v2,1/2] gnu: python-libsass: Update to 0.22.0. | expand

Commit Message

Sharlatan Hellseher Sept. 5, 2023, 10:24 p.m. UTC
* gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix
build.
[native-inputs]: Add python-flaky.
---
 gnu/packages/python-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Christopher Baines Sept. 13, 2023, 8:46 a.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix
> build.
> [native-inputs]: Add python-flaky.
> ---
>  gnu/packages/python-xyz.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Thanks, I've pushed both of these patches to master as
7f150a18957daddb53caf11e23eb12122198d65c.

I tweaked the commit message in the first one just to mention the update
in the first line, then the previously failing tests later.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cdf5ee6293..1d273bbb4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30009,7 +30009,7 @@  (define-public python-helper
 (define-public python-qtsass
   (package
     (name "python-qtsass")
-    (version "0.3.0")
+    (version "0.4.0")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -30019,7 +30019,7 @@  (define-public python-qtsass
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "09s04aa14d8jqbh71clrb5y7vcmkxlp94mwmvzrkxahry3bk03cb"))))
+        (base32 "1skdihfby2f41zxgwa5zv44vdxjrw301rh88rjmzj4xbdlix6cig"))))
     (build-system python-build-system)
     (arguments
      `(#:test-target "pytest"
@@ -30031,7 +30031,7 @@  (define-public python-qtsass
              (for-each make-file-writable (find-files "."))
              #t)))))
     (native-inputs
-     (list python-pytest python-pytest-cov python-pytest-runner))
+     (list python-flaky python-pytest python-pytest-cov python-pytest-runner))
     (propagated-inputs
      (list python-libsass))
     (home-page "https://github.com/spyder-ide/qtsass")