diff mbox series

[bug#70057] gnu: borgmatic: Update to 1.8.9.

Message ID bb9eb4064136798fdead3fe9338990c974abb37b.1711649468.git.me@fabionatali.com
State New
Headers show
Series [bug#70057] gnu: borgmatic: Update to 1.8.9. | expand

Commit Message

Fabio Natali March 28, 2024, 7:05 p.m. UTC
* gnu/packages/backup.scm (borgmatic): Update to 1.8.9.

Change-Id: I28330c4f864b7f15c50fc6c80c5d9c40af91b6b9
---
Hi,

This is to update borgmatic to 1.8.9.

I'm sending this as a follow up to another patch, re python-apprise. In fact,
Apprise is now a borgmatic dependency, at least for some of its new
functionality (notifications).

I'm sorry, I should have probably started this as a patch series, with a short
introductory email. I hope it's still clear and easily reviewable.

Thanks, cheers, Fabio.


 gnu/packages/backup.scm | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)


base-commit: fb9549164520ad993c2fbbaedc899844d57baabc
prerequisite-patch-id: d9e77adec47d85410e146267e3373f4d3a110832
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 253ab74a19..300f2825c6 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1308,13 +1308,13 @@  (define-public disarchive
 (define-public borgmatic
   (package
     (name "borgmatic")
-    (version "1.7.12")
+    (version "1.8.9")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgmatic" version))
        (sha256
-        (base32 "0720wvs3h2w8h28d7mpvjfp0q37dnrwf1y2ik3y4yr9csih7fmgh"))))
+        (base32 "1xmqv0gg2ic7lp5kmygr9f6qkabsr86mma7pigan12vk2bcdbw31"))))
     (build-system python-build-system)
     (arguments
      (list #:phases
@@ -1339,11 +1339,19 @@  (define-public borgmatic
                      (setenv "PATH" (string-append #$output "/bin"
                                                    ":" (getenv "PATH")))
                      (invoke "pytest")))))))
-    (inputs
-     (list borg python-colorama python-jsonschema python-requests
-           python-ruamel.yaml-0.16))
-    (native-inputs
-     (list python-flexmock python-pytest python-pytest-cov))
+    (inputs (list borg
+                  python-apprise
+                  python-colorama
+                  python-jsonschema
+                  python-requests))
+    (native-inputs (list python-flexmock
+                         python-pytest
+                         python-pytest-cov))
+    (propagated-inputs (list python-colorama
+                             python-jsonschema
+                             python-packaging
+                             python-requests
+                             python-ruamel.yaml))
     (home-page "https://torsion.org/borgmatic/")
     (synopsis "Simple, configuration-driven backup software")
     (description