diff mbox series

[bug#74290,19/31] gnu: openssl-3.0: Support the 64bit Hurd.

Message ID bb85fef425df3d9a07dce34dc73acdbedc1717f6.1731232753.git.janneke@gnu.org
State New
Headers show
Series Add support for x86_64-gnu, aka the 64bit Hurd. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 10, 2024, 10:38 a.m. UTC
* gnu/packages/patches/openssl-hurd64.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/tls.scm (openssl-3.0)[arguments]: When building for
the 64bit Hurd, use it in new "apply-hurd-patch" phase.

Change-Id: I8936377da726681b748cc010e1fbae3fb19dee05
---
 gnu/local.mk                              |  1 +
 gnu/packages/patches/openssl-hurd64.patch | 99 +++++++++++++++++++++++
 gnu/packages/tls.scm                      |  9 +++
 3 files changed, 109 insertions(+)
 create mode 100644 gnu/packages/patches/openssl-hurd64.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 4b9fa95658..576f60579e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1891,6 +1891,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/opensles-add-license-file.patch			\
   %D%/packages/patches/openssl-1.1-c-rehash-in.patch		\
   %D%/packages/patches/openssl-3.0-c-rehash-in.patch		\
+  %D%/packages/patches/openssl-hurd64.patch			\
   %D%/packages/patches/opentaxsolver-file-browser-fix.patch     \
   %D%/packages/patches/open-zwave-hidapi.patch			\
   %D%/packages/patches/orangeduck-mpc-fix-pkg-config.patch	\
diff --git a/gnu/packages/patches/openssl-hurd64.patch b/gnu/packages/patches/openssl-hurd64.patch
new file mode 100644
index 0000000000..372fda834a
--- /dev/null
+++ b/gnu/packages/patches/openssl-hurd64.patch
@@ -0,0 +1,99 @@ 
+Upstream-status: Taken from upstream:
+
+<https://github.com/openssl/openssl/commit/7c729851d169f30d9e0c0ad6e7c1cf6cefb37935>.
+
+From 795699363be8f717e36802c3ac503011b74ad752 Mon Sep 17 00:00:00 2001
+From: Janneke Nieuwenhuizen <janneke@gnu.org>
+Date: Thu, 7 Nov 2024 14:08:05 +0100
+Subject: [PATCH] Add support for the 64bit Hurd.
+Content-Transfer-Encoding: 8bit
+Content-Type: text/plain; charset=UTF-8
+
+Taken from <https://salsa.debian.org/debian/openssl>.
+---
+ Configurations/10-main.conf | 45 ++++++++++++++++++++++++++++++++-----
+ util/perl/OpenSSL/config.pm |  3 ++-
+ 2 files changed, 41 insertions(+), 7 deletions(-)
+
+diff --git a/Configurations/10-main.conf b/Configurations/10-main.conf
+index b578a3c2a8..740460ebd3 100644
+--- a/Configurations/10-main.conf
++++ b/Configurations/10-main.conf
+@@ -1685,20 +1685,53 @@ my %targets = (
+     },
+ 
+ ##### GNU Hurd
+-    "hurd-x86" => {
++    "hurd-generic32" => {
+         inherit_from     => [ "BASE_unix" ],
+         CC               => "gcc",
+-        CFLAGS           => "-O3 -fomit-frame-pointer -Wall",
++        CXX              => "g++",
++        CFLAGS           => picker(default => "-Wall",
++                                   debug   => "-O0 -g",
++                                   release => "-O3"),
++        CXXFLAGS         => picker(default => "-Wall",
++                                   debug   => "-O0 -g",
++                                   release => "-O3"),
+         cflags           => threads("-pthread"),
+-        lib_cppflags     => "-DL_ENDIAN",
++        cxxflags         => combine("-std=c++11", threads("-pthread")),
+         ex_libs          => add("-ldl", threads("-pthread")),
+-        bn_ops           => "BN_LLONG",
+-        asm_arch         => 'x86',
+-        perlasm_scheme   => 'elf',
++        bn_ops           => "BN_LLONG RC4_CHAR",
+         thread_scheme    => "pthreads",
+         dso_scheme       => "dlfcn",
+         shared_target    => "linux-shared",
+         shared_cflag     => "-fPIC",
++        shared_ldflag    => sub { $disabled{pinshared} ? () : "-Wl,-znodelete" },
++    },
++
++    "hurd-generic64" => {
++        inherit_from     => [ "hurd-generic32" ],
++        bn_ops           => "SIXTY_FOUR_BIT_LONG RC4_CHAR",
++    },
++
++    #### X86 / X86_64 targets
++    "hurd-x86" => {
++        inherit_from     => [ "hurd-generic32" ],
++        CFLAGS           => add(picker(release => "-fomit-frame-pointer")),
++        cflags           => add("-m32"),
++        cxxflags         => add("-m32"),
++        lib_cppflags     => add("-DL_ENDIAN"),
++        bn_ops           => "BN_LLONG",
++        asm_arch         => 'x86',
++        perlasm_scheme   => 'elf',
++    },
++
++    "hurd-x86_64" => {
++        inherit_from     => [ "hurd-generic64" ],
++        cflags           => add("-m64"),
++        cxxflags         => add("-m64"),
++        lib_cppflags     => add("-DL_ENDIAN"),
++        bn_ops           => "SIXTY_FOUR_BIT_LONG",
++        asm_arch         => 'x86_64',
++        perlasm_scheme   => 'elf',
++        multilib         => "64",
+     },
+ 
+ ##### VxWorks for various targets
+diff --git a/util/perl/OpenSSL/config.pm b/util/perl/OpenSSL/config.pm
+index 2f1edcafb6..707db71537 100755
+--- a/util/perl/OpenSSL/config.pm
++++ b/util/perl/OpenSSL/config.pm
+@@ -92,7 +92,8 @@ my $guess_patterns = [
+     [ 'IRIX64:.*',                  'mips4-sgi-irix64' ],
+     [ 'Linux:[2-9]\..*',            '${MACHINE}-whatever-linux2' ],
+     [ 'Linux:1\..*',                '${MACHINE}-whatever-linux1' ],
+-    [ 'GNU.*',                      'hurd-x86' ],
++    [ 'GNU:.*86-AT386',             'hurd-x86' ],
++    [ 'GNU:.*86_64-AT386',          'hurd-x86_64' ],
+     [ 'LynxOS:.*',                  '${MACHINE}-lynx-lynxos' ],
+     # BSD/OS always says 386
+     [ 'BSD\/OS:4\..*',              'i486-whatever-bsdi4' ],
+-- 
+Janneke Nieuwenhuizen <janneke@gnu.org>  | GNU LilyPond https://LilyPond.org
+Freelance IT https://www.JoyOfSource.com | AvatarĀ® https://AvatarAcademy.com
+
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 1a1ce0d215..261a063090 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -589,6 +589,15 @@  (define-public openssl-3.0
                                            "/bin/perl"))))
             #$@(if (target-hurd?)
                    #~((delete 'patch-configure))
+                   #~())
+            #$@(if (target-hurd64?)
+                   #~((add-after 'unpack 'apply-hurd-patch
+                        (lambda _
+                          (let ((patch-file
+                                 #$(local-file
+                                    (search-patch "openssl-hurd64.patch"))))
+                            (invoke "patch" "--force" "-p1" "-i"
+                                    patch-file)))))
                    #~())))
        ((#:configure-flags flags #~'())
         (if (system-hurd?)