diff mbox series

[bug#65777,1/2] gnu: npiet: fix cross-compile.

Message ID bb692cd776f2a50d7e8a7d9c3623bd7a18a1aae4.1693993064.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series npiet: fix cross-compile. | expand

Commit Message

Z572 Sept. 6, 2023, 9:46 a.m. UTC
* gnu/packages/piet.scm (npiet): fix cross-compile.
[arguments]<#:phases>: Use SEARCH-INPUT-FILE replace WHICH.
---
 gnu/packages/piet.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
index 824efe59de..8e5a313e82 100644
--- a/gnu/packages/piet.scm
+++ b/gnu/packages/piet.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,10 +47,12 @@  (define-public npiet
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap-binaries
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (wrap-program (string-append out "/bin/npietedit")
-                 `("PATH" ":" prefix (,(dirname (which "wish")))))
+                 `("PATH" ":" prefix
+                   (,(dirname
+                      (search-input-file inputs "bin/wish")))))
                #t))))))
     (inputs
      (list gd giflib libpng tk))