diff mbox series

[bug#50490,3/5] gnu: Add julia-mlstyle.

Message ID bb560a406d99c1b3f25cc4f1316644af5bdc394d.1631211286.git.efraim@flashner.co.il
State Accepted
Headers show
Series Some julia packages | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Sept. 22, 2021, 12:13 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-mlstyle): New variable.
---
 gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Simon Tournier Sept. 27, 2021, 4:54 p.m. UTC | #1
Hi Efraim,

On mer., 22 sept. 2021 at 15:13, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-mlstyle): New variable.
> ---
>  gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
> index 222f9f129e..3616ffd006 100644
> --- a/gnu/packages/julia-xyz.scm
> +++ b/gnu/packages/julia-xyz.scm
> @@ -2508,6 +2508,28 @@ resolving them into absolute units.")
>  with @code{missing} values in Julia.")
>      (license license:expat)))
>
> +(define-public julia-mlstyle
> +  (package
> +    (name "julia-mlstyle")
> +    (version "0.4.10")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/thautwarm/MLStyle.jl")
> +               (commit (string-append "v" version))))
> +        (file-name (git-file-name name version))
> +        (sha256
> +         (base32 "0h1cd7cr4c4cnpqyj3180113gdbvcc047lqphp8a8gq5smp3c059"))))
> +    (build-system julia-build-system)
> +    (native-inputs
> +     `(("julia-datastructures" ,julia-datastructures)))
> +    (home-page "https://thautwarm.github.io/MLStyle.jl/latest/")
> +    (synopsis "Julia functional programming infrastructures")
> +    (description "This package provides consistent and extensible functional
> +programming infrastructures, and metaprogramming facilities.")
> +    (license license:expat)))

LGTM.  I notice that the package raises warning at the check phase.

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 222f9f129e..3616ffd006 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2508,6 +2508,28 @@  resolving them into absolute units.")
 with @code{missing} values in Julia.")
     (license license:expat)))
 
+(define-public julia-mlstyle
+  (package
+    (name "julia-mlstyle")
+    (version "0.4.10")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/thautwarm/MLStyle.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0h1cd7cr4c4cnpqyj3180113gdbvcc047lqphp8a8gq5smp3c059"))))
+    (build-system julia-build-system)
+    (native-inputs
+     `(("julia-datastructures" ,julia-datastructures)))
+    (home-page "https://thautwarm.github.io/MLStyle.jl/latest/")
+    (synopsis "Julia functional programming infrastructures")
+    (description "This package provides consistent and extensible functional
+programming infrastructures, and metaprogramming facilities.")
+    (license license:expat)))
+
 (define-public julia-mocking
   (package
     (name "julia-mocking")