diff mbox series

[bug#48232,2/2] gnu: mercurial: Add PYTHONPATH to

Message ID bb3bf9711cfb03214786407afe8fd67019c0c4fa.1620159508.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add mercurial-commitsigs and some changes to Mercurial. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen May 4, 2021, 9 p.m. UTC
This will make Mercurial be able to find third-party extensions.

* gnu/packages/version-control.scm (mercurial)[native-search-paths]: Add
PYTHONPATH.
---
 gnu/packages/version-control.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3a1cb33fc3..9711516609 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1709,6 +1709,11 @@  execution of any hook written in any language before every commit.")
      `(("python-nose" ,python-nose)
        ("unzip" ,unzip)
        ("which" ,which)))
+    ;; Find third-party extensions.
+    (native-search-paths
+     (list (search-path-specification
+            (variable "PYTHONPATH")
+            (files '("lib/python3.8/site-packages/hgext3rd")))))
     (home-page "https://www.mercurial-scm.org/")
     (synopsis "Decentralized version control system")
     (description