diff mbox series

[bug#42462,1/2] gnu: freedink-engine: Call autoreconf.

Message ID bb1b9195-e434-4525-4450-c709bee402be@gmail.com
State Accepted
Headers show
Series freedink: fix build | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:42 a.m. UTC
* gnu/packages/games.scm: freedink-engine (phases): add 'autoreconf
---
gnu/packages/games.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

("cxxtest" ,cxxtest)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dc0511e55a..835c8c5f52 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2743,7 +2743,16 @@  interface or via an external visual interface 
such as GNU XBoard.")
;; These tests require a graphical interface.
(substitute* "src/Makefile.am"
(("test_gfx_fonts TestIOGfxDisplay") ""))
- #t)))))
+ #t))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; automake is out of date in the source
+ ;; autoreconf updates the automake scripts
+ (invoke "autoreconf")
+ ;; Build fails when autom4te.cache exists.
+ (delete-file-recursively "autom4te.cache")
+ #t))
+ )))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)