diff mbox series

[bug#69134] gnu: Add python-ega-download-client.

Message ID bb1b0092bc31e21d2745955d2e3d83cb1ca5003c.1707942466.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#69134] gnu: Add python-ega-download-client. | expand

Commit Message

nafkhamdc Feb. 14, 2024, 8:27 p.m. UTC
* gnu/packages/bioinformatics.scm (python-ega-download-client): New variable.

Change-Id: I3233774975989f912281ab2e6ec6ad3362cae18b
---
 gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 2ba2875dbda4b080fcad4e6d672bb4104d59dd0c

Comments

Ricardo Wurmus Feb. 15, 2024, 10:54 a.m. UTC | #1
Thanks for the patch.  I pushed it to the master branch with commit
fb79e589957880c95bb4e8e57e2a5023c8a696d6.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bcfe3c2656..863bf1ff26 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2525,6 +2525,43 @@  (define-public python-pybedtools
     ;; licensed lgpl2.1+
     (license (list license:expat license:lgpl2.1+))))
 
+(define-public python-ega-download-client
+  (package
+    (name "python-ega-download-client")
+    (version "5.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/EGA-archive/ega-download-client")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0k9rfq2yyvfxs5sq9lsm8krp9ddx4s18hv85ikf3b37zv24kpwjk"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags '(list "-k"
+                          ;; These tests fail because they require internet access.
+                          (string-append "not test_download.py"
+                                         " and not test_htsget.py"
+                                         " and not test_commands.py"))
+      #:phases '(modify-phases %standard-phases
+                  (add-after 'unpack 'relax-requirements
+                    (lambda _
+                      (substitute* "setup.py"
+                        (("==")
+                         ">=")))))))
+    (propagated-inputs (list python-htsget python-psutil python-requests
+                             python-tqdm python-urllib3))
+    (native-inputs (list python-coverage python-pytest python-pyfakefs
+                         python-responses))
+    (home-page "https://github.com/EGA-archive/ega-download-client")
+    (synopsis "EGA download client: pyEGA3")
+    (description
+     "PyEGA3 is a tool for viewing and downloading files from authorized EGA datasets.")
+    (license license:asl2.0)))
+
 (define-public python-scdamandtools
   (package
     (name "python-scdamandtools")