diff mbox series

[bug#38157] gnu: Add font-dseg.

Message ID bb0edb84873dbde7dfa45500d75fd40672a32f65.camel@zrythm.org
State Accepted
Headers show
Series [bug#38157] gnu: Add font-dseg. | expand

Commit Message

Alexandros Theodotou Nov. 10, 2019, 3:20 a.m. UTC
There's probably an easy way to remove the dot from the version but I
can't figure it out. Any modifications welcome.

Comments

ashish.is--- via Guix-patches" via Nov. 10, 2019, 12:35 p.m. UTC | #1
Alexandros,

Thanks for all these patches!  I look forward to trying Zrythm 
when it comes to Guix.

Alexandros Theodotou 写道:
> There's probably an easy way to remove the dot from the version 
> but I
> can't figure it out. Any modifications welcome.

You could

    (apply string-append (string-split version #\.))
or

    (string-join (string-split version #\.) "")

I think I prefer the STRING-APPEND version but both are fine.

Kind regards,

T G-R
diff mbox series

Patch

From f82f0cbdf74a2477c6894796090de9ffc3e2aea8 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sun, 10 Nov 2019 01:25:28 +0000
Subject: [PATCH] gnu: Add font-dseg.

* gnu/packages/fonts.scm (font-dseg): New variable.
---
 gnu/packages/fonts.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index bb6dc45d94..053b5d4530 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
 ;;; Copyright © 2019 Alva <alva@skogen.is>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1524,3 +1525,38 @@  Symbols stand out from common text.  Dots and commas are easily seen, and
 operators are clear even when not surrounded by spaces.  Similar characters
 have been designed to be very distinguishable from each other.")
     (license license:silofl1.1)))
+
+(define-public font-dseg
+  (package
+    (name "font-dseg")
+    (version "0.45")
+    (source
+      (origin
+        (method url-fetch/zipbomb)
+        (uri
+          (string-append "https://github.com/keshikan/DSEG/"
+                         "releases/download/v" version
+                         ;; not sure how to remove dot from version
+                         "/fonts-DSEG_v045.zip"))
+        (sha256
+          (base32
+            "0v8sghh4vl286faf8pvi74znz07pyf0qii8z4wjllisqwc35sx72"))))
+    (build-system font-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (font-dir (string-append out "/share/fonts"))
+                    (truetype-dir (string-append font-dir "/truetype")))
+               (with-directory-excursion "fonts-DSEG_v045"
+                 (for-each (lambda (f) (install-file f truetype-dir))
+                           (find-files "." "\\.ttf$"))
+               #t)))))))
+    (home-page "https://www.keshikan.net/fonts-e.html")
+    (synopsis "DSEG: 7-segment and 14-segment fonts")
+    (description
+     "DSEG is a font family that imitates seven and fourteen segment
+display (7SEG,14SEG). DSEG includes the roman alphabet and symbol glyphs.")
+    (license license:silofl1.1)))
-- 
2.24.0