[bug#77441] gnu: compsize: Remove.

Message ID ba9278c75b021a416b44d0f50c6c379194ba2607.1743546397.git.ludo@gnu.org
State New
Headers
Series [bug#77441] gnu: compsize: Remove. |

Commit Message

Ludovic Courtès April 1, 2025, 10:30 p.m. UTC
  This package fails to build with btrfs-progs@6.3.3 and hasn’t seen any
activity upstream since Dec. 2023.

* gnu/packages/linux.scm (compsize): Remove.

Change-Id: I30513d8fbda362c49c763300db7a7ff41e81a38c
---
 gnu/packages/linux.scm | 44 ------------------------------------------
 1 file changed, 44 deletions(-)

Hi,

The ‘compsize’ package fails to build since the e2fsprogs and btrfs-progs
upgrades from <https://issues.guix.gnu.org/75119> (commit
7cef57e2a7dedd3eea0ba5852915eaf10f00e9f4).

According to the deprecation policy, this patch can be applied in one month
if there are no objections, on May 2nd.

Ludo’.


base-commit: eb04a0d2c955f5fa9a721537c8202fc5c5959b19
  

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2c587baac0..7fa36306cc 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6887,50 +6887,6 @@  (define-public cramfs-tools
 blocks and random block placement.")
     (license license:gpl2+)))
 
-(define-public compsize
-  (package
-    (name "compsize")
-    (version "1.5")
-    (home-page "https://github.com/kilobyte/compsize")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url home-page)
-                    (commit (string-append "v" version))))
-              (sha256
-               (base32 "0vqnrwgpv6pc1yjl0g4gl71xyl6v0xl3pyqjanjpwps73c53azir"))
-              (file-name (git-file-name name version))))
-    (build-system gnu-build-system)
-    (inputs
-     (list btrfs-progs))
-    (arguments
-     `(#:tests? #f                      ; No tests.
-       #:make-flags
-       (list (string-append "CC=" ,(cc-for-target)))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (install-file "compsize" (string-append out "/bin"))
-               (install-file "compsize.8" (string-append out "/share/man/man8"))))))))
-    (synopsis "Find compression type/ratio on Btrfs files")
-    (description "@command{compsize} takes a list of files (given as
-arguments) on a Btrfs file system and measures used compression types and
-effective compression ratio, producing a report.
-
-A directory has no extents but has a (recursive) list of files.  A non-regular
-file is silently ignored.
-
-As it makes no sense to talk about compression ratio of a partial extent,
-every referenced extent is counted whole, exactly once -- no matter if you use
-only a few bytes of a 1GB extent or reflink it a thousand times.  Thus, the
-uncompressed size will not match the number given by @command{tar} or
-@command{du}.  On the other hand, the space used should be accurate (although
-obviously it can be shared with files outside our set).")
-    (license license:gpl2+)))
-
 (define-public f2fs-tools
   (package
     (name "f2fs-tools")