diff mbox series

[bug#43417] gnu: Add libsoundio.

Message ID ba8632337e6f8676da41b37d34a86a81ce407985.camel@zrythm.org
State Accepted
Headers show
Series [bug#43417] gnu: Add libsoundio. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Sept. 15, 2020, 9:22 a.m. UTC
Hi,

This patch adds libsoundio.

Thanks,
Alex

Comments

Mathieu Othacehe Sept. 18, 2020, 1:02 p.m. UTC | #1
Hello,

> * gnu/packages/audio.scm (libsoundio): New variable.

I fixed the indentation and pushed.

Thanks,

Mathieu
diff mbox series

Patch

From bca9b2fb17e63a60b70f6659272b1bba884aa9e7 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 15 Sep 2020 10:17:15 +0100
Subject: [PATCH] gnu: Add libsoundio.

* gnu/packages/audio.scm (libsoundio): New variable.
---
 gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 38ee4f8bcc..0b71901ff5 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4464,6 +4464,36 @@  supports both of ID3v1/v2 and APEv2 tags.")
     (home-page "http://tausoft.org/")
     (license license:gpl2+)))
 
+(define-public libsoundio
+  (package
+   (name "libsoundio")
+   (version "2.0.0")
+   (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/andrewrk/libsoundio")
+              (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32
+           "12l4rvaypv87vigdrmjz48d4d6sq4gfxf5asvnc4adyabxb73i4x"))))
+   (build-system cmake-build-system)
+   (arguments
+    `(#:tests? #f)) ; no tests included
+   (inputs
+    `(("alsa-lib" ,alsa-lib)
+      ("jack" ,jack-1)
+      ("pulseaudio" ,pulseaudio)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (home-page "http://libsound.io")
+   (synopsis "C library for real-time audio input and output")
+   (description "libsoundio is a C library providing audio input and output.
+The API is suitable for real-time software such as digital audio workstations
+as well as consumer software such as music players.")
+   (license license:expat)))
+
 (define-public redkite
   (package
     (name "redkite")
-- 
2.27.0