diff mbox series

[bug#69482] gnu: hikari: fix build.

Message ID ba2edf5ac31fc00b13d961ef220754dc4bbdee35.1709246434.git.stuebinm@disroot.org
State New
Headers show
Series [bug#69482] gnu: hikari: fix build. | expand

Commit Message

terru Feb. 29, 2024, 10:40 p.m. UTC
It fails to build with versions of wlroots newer than 0.15, which
seems unlikey to be fixed https://hub.darcs.net/raichoo/hikari/issue/45

* gnu/packages/wm.scm (wlroots-0.15): New variable.
* gnu/packages/wm.scm (hikari)[inputs]: Replace wlroots with wlroots-0.15.

Change-Id: Id90e1e1ff399afe54fff68167f497f0484d2c218
---

Hi everyone! I'm new to Guix, so I hope I'm doing this right. Unfortunately,
hikari seems to be unmaintained for now (see the linked issue, now almost
two years old; asking on their Matrix chat also led to no result).

With this change, hikari builds again, though I could also understand if
it's preferred to remove it entirely over keeping old versions of wlroots
around.

 gnu/packages/wm.scm | 17 ++++++++++++++++-
 1 file changed, 16 insertions(+), 1 deletion(-)


base-commit: b988248e1c88bde3001b7f2b1830dececa7e8b23

Comments

Ludovic Courtès March 19, 2024, 4:14 p.m. UTC | #1
Hi,

stuebinm <stuebinm@disroot.org> skribis:

> It fails to build with versions of wlroots newer than 0.15, which
> seems unlikey to be fixed https://hub.darcs.net/raichoo/hikari/issue/45
>
> * gnu/packages/wm.scm (wlroots-0.15): New variable.
> * gnu/packages/wm.scm (hikari)[inputs]: Replace wlroots with wlroots-0.15.
>
> Change-Id: Id90e1e1ff399afe54fff68167f497f0484d2c218

I tweaked the commit log and applied it.

> Hi everyone! I'm new to Guix, so I hope I'm doing this right. Unfortunately,
> hikari seems to be unmaintained for now (see the linked issue, now almost
> two years old; asking on their Matrix chat also led to no result).
>
> With this change, hikari builds again, though I could also understand if
> it's preferred to remove it entirely over keeping old versions of wlroots
> around.

Maybe something to consider going forward.  We’ll see.

Thank you!

Ludo’.
terru March 21, 2024, 10:26 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:
> I tweaked the commit log and applied it.

Thanks!

btw, I noticed too late that there was already an older issue about this
from a year ago, which should perhaps also be marked as closed now:
https://issues.guix.gnu.org/63426

 ~terru
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 768fbc5bc7..afa60bf3ad 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1757,6 +1757,21 @@  (define-public wlroots-0.16
     (propagated-inputs (modify-inputs (package-propagated-inputs wlroots)
                          (delete libdisplay-info)))))
 
+(define-public wlroots-0.15
+  (package
+    (inherit wlroots)
+    (name "wlroots-0.15")
+    (version "0.15.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.freedesktop.org/wlroots/wlroots")
+             (commit version)))
+       (file-name (git-file-name "wlroots" version))
+       (sha256
+        (base32 "00s73nhi3sc48l426jdlqwpclg41kx1hv0yk4yxhbzw19gqpfm1h"))))))
+
 (define-public sway
   (package
     (name "sway")
@@ -3221,7 +3236,7 @@  (define-public hikari
            linux-pam
            pango
            wayland
-           wlroots-0.16))
+           wlroots-0.15))
     (arguments
      `(#:tests? #f                      ; no tests
        #:make-flags