[bug#75420,python-team,04/11] gnu: Add python-aiohappyeyeballs.

Message ID ba1f1966cc91be58709b0589c1cae18c7b3e2d1d.1736256868.git.arjan@adriaan.se
State New
Headers
Series Fix python-matrix-nio and pantalaimon builds. |

Commit Message

Arjan Adriaanse Jan. 7, 2025, 2:09 p.m. UTC
  * gnu/packages/python-web.scm (python-aiohappyeyeballs): New variable.

Change-Id: I7753327674b667c44e314d055b9d58f3097cb71b
---
 gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 56e2d2aa39..15c43691d5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -791,6 +791,29 @@  (define-public python-aiohttp
 @end itemize")
     (license license:asl2.0)))
 
+(define-public python-aiohappyeyeballs
+  (package
+    (name "python-aiohappyeyeballs")
+    (version "2.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "aiohappyeyeballs" version))
+       (sha256
+        (base32 "0ibpfm552pflim399qq34cnd79xhz5qr5khqzhx1hqwwi23pvpaz"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-poetry-core
+           python-pytest
+           python-pytest-asyncio
+           python-pytest-cov))
+    (home-page "https://github.com/aio-libs/aiohappyeyeballs")
+    (synopsis "Happy Eyeballs for asyncio")
+    (description "@code{aiohappyeyeballs} allows connecting with Happy
+Eyeballs (RFC 8305) when you already have a list of @code{addrinfo} and not a
+DNS name.")
+    (license license:psfl)))
+
 (define-public python-aiohttp-socks
   (package
     (name "python-aiohttp-socks")