[bug#77154,v3,1/2] gnu: libssh2: Update to 1.11.1
Commit Message
* gnu/packages/ssh.scm (libssh2): Update to 1.11.1
[arguments]: Disable tests which requires docker
Change-Id: I1bfd8f2db82c190f2b036b3e2e722ded90d07435
---
gnu/packages/ssh.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
base-commit: efac1498c15198afc4f9a2bc700408bde1b3b3ed
@@ -181,7 +181,7 @@ (define-public libssh
(define-public libssh2
(package
(name "libssh2")
- (version "1.10.0")
+ (version "1.11.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -189,14 +189,15 @@ (define-public libssh2
version ".tar.gz"))
(sha256
(base32
- "0l8xwhhscvss7q007vpbkbv7jh9s43579rx2sf8lnfgd7l7yjr1d"))))
+ "1xsqysmrq40gdfjndd1yrcvwic16kn4jrzir6pn8xfadwg5pdv6r"))))
(build-system gnu-build-system)
;; The installed libssh2.pc file does not include paths to libgcrypt and
;; zlib libraries, so we need to propagate the inputs.
(propagated-inputs (list libgcrypt zlib))
(arguments
(list #:configure-flags #~'("--with-libgcrypt"
- "--disable-static")))
+ "--disable-static"
+ "--disable-docker-tests" )))
(synopsis "Client-side C library implementing the SSH2 protocol")
(description
"libssh2 is a library intended to allow software developers access to