diff mbox series

[bug#67076] gnu: zix: Update to 0.4.2.

Message ID b9f8cd4571826d1caa12d0b8fa2e2655b658d1f8.1699713082.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#67076] gnu: zix: Update to 0.4.2. | expand

Commit Message

Z572 Nov. 11, 2023, 2:31 p.m. UTC
* gnu/packages/datastructures.scm (zix): Update to 0.4.2.

Change-Id: I4465ff6eefbdbb7a3de1806fc4adbec285fa26a1
---
 gnu/packages/datastructures.scm | 45 ++++++++++++++++-----------------
 1 file changed, 22 insertions(+), 23 deletions(-)


base-commit: af6105afc67a15a491a0a4fd18a28c9f801a0b94

Comments

Mathieu Othacehe Nov. 25, 2023, 1:39 p.m. UTC | #1
> * gnu/packages/datastructures.scm (zix): Update to 0.4.2.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 0689ef4259..c6b2396537 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -444,28 +445,26 @@  (define-public robin-map
     (license license:expat)))
 
 (define-public zix
-  (let ((commit "a13ae5ad9dc70075740f11139f1db96cc79faa59")
-        (revision "0"))
-    (package
-      (name "zix")
-      (version (git-version "0.3.3" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://gitlab.com/drobilla/zix.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1njyb8lz1d5qzf0k14pb3rq13xkxnddwbz090dj69138ymz1xgyl"))))
-      (build-system meson-build-system)
-      (arguments
-       (list #:configure-flags #~(list "-Ddocs=disabled"))) ;needs "sphinxygen"
-      (native-inputs (list pkg-config))
-      (home-page "https://gitlab.com/drobilla/zix")
-      (synopsis "C library of portability wrappers and data structures")
-      (description
-       "Zix is a C library of portability wrappers and data structures.  It
+  (package
+    (name "zix")
+    (version "0.4.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/drobilla/zix.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07pbq4bi64iv39swldfbcp7131b5n4hs64pgd417gqlwv8qvgjcw"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:configure-flags #~(list "-Ddocs=disabled"))) ;needs "sphinxygen"
+    (native-inputs (list pkg-config))
+    (home-page "https://gitlab.com/drobilla/zix")
+    (synopsis "C library of portability wrappers and data structures")
+    (description
+     "Zix is a C library of portability wrappers and data structures.  It
 provides the following components:
 @table @code
 @item ZixAllocator A customizable allocator.
@@ -480,4 +479,4 @@  (define-public zix
 zix/filesystem.h Functions for working with filesystems.
 @item zix/path.h Functions for working with filesystem paths lexically.
 @end table")
-      (license license:isc))))
+    (license license:isc)))