diff mbox series

[bug#64188,1/8] gnu: %gcc-11-x86_64-micro-architectures: Add generic options.

Message ID b9c84a8dd7e1cd2df121e7132fc8369bd6164b9d.1687247150.git.efraim@flashner.co.il
State New
Headers show
Series More package tuning | expand

Commit Message

Efraim Flashner June 20, 2023, 7:51 a.m. UTC
* gnu/packages/gcc.scm (%gcc-11-x86_64-micro-architectures): Add entries
for x86_64-v{1,2,3,4}.
---
 gnu/packages/gcc.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès June 25, 2023, 8:49 p.m. UTC | #1
Efraim Flashner <efraim@flashner.co.il> skribis:

> * gnu/packages/gcc.scm (%gcc-11-x86_64-micro-architectures): Add entries
> for x86_64-v{1,2,3,4}.

[...]

> +            "x86_64-v1" "x86_64-v2" "x86_64-v3" "x86_64-v4")))  ; Generic

Nitpick: I’d call it “psABI micro-architecture levels” because I think
that’s what the SysV psABI document calls them.

Otherwise LGTM!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1b444c2b02..f5736de993 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -614,7 +614,9 @@  (define %gcc-11-x86_64-micro-architectures
   (append %gcc-10-x86_64-micro-architectures
           '("sapphirerapids" "alterlake" "rocketlake" ;Intel
 
-            "btver1" "btver2")))                  ;AMD
+            "btver1" "btver2"                     ;AMD
+
+            "x86_64-v1" "x86_64-v2" "x86_64-v3" "x86_64-v4")))  ; Generic
 
 ;; Suitable '-march' values for GCC 12.
 (define %gcc-12-aarch64-micro-architectures