diff mbox series

[bug#66936,v2] gnu: wine-staging: Update to 8.18.

Message ID b9c79e013e3dcb3aeca793745a84931257e287c2.1702145463.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#66936,v2] gnu: wine-staging: Update to 8.18. | expand

Commit Message

Kaelyn Takata Dec. 9, 2023, 6:11 p.m. UTC
* gnu/packages/wine.scm (wine-staging): Update to 8.18.
(wine-staging-patchset-data)[#:builder]: Adjust accordingly.
[native-inputs]: Drop bash.
(wine-staging)[native-inputs]: Add python-3.
[#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
(wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.

Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
---
 gnu/packages/wine.scm | 21 ++++++++++-----------
 1 file changed, 10 insertions(+), 11 deletions(-)


base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34

Comments

Kaelyn Takata Dec. 24, 2023, 3:47 p.m. UTC | #1
Hi guix-devel,

I just sent out https://issues.guix.gnu.org/68005 to remove dxvk 1.5.5, which as far as I can tell has been broken for a few years now (IIRC I tested as far back in guix history as wine-staging 5.13 or 5.22 from 2-3 years ago and still encountered the same errors building dxvk). I wanted to bump this 2+ week old update to wine-staging since dxvk is the only dependent on wine-staging and it does not currently build (and the QA status of bug #66936 is still "Pending").

Cheers,
Kaelyn


On Saturday, December 9th, 2023 at 10:11 AM, Kaelyn Takata <kaelyn.alexi@protonmail.com> wrote:

> 
> * gnu/packages/wine.scm (wine-staging): Update to 8.18.
> (wine-staging-patchset-data)[#:builder]: Adjust accordingly.
> [native-inputs]: Drop bash.
> (wine-staging)[native-inputs]: Add python-3.
> [#:phases]<apply-wine-staging-patches>: Adjust path to patch script.
> 
> (wine64-staging)[#:phases]<apply-wine-staging-patches>: Likewise.
> 
> 
> Change-Id: Ie71ed785c1e821b1d1752e46b3da11809b4331e5
> ---
> gnu/packages/wine.scm | 21 ++++++++++-----------
> 1 file changed, 10 insertions(+), 11 deletions(-)
> 
> diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
> index 400f0e7607..48f7499ba2 100644
> --- a/gnu/packages/wine.scm
> +++ b/gnu/packages/wine.scm
> @@ -304,7 +304,7 @@ (define-public wine64
> (define-public wine-staging-patchset-data
> (package
> (name "wine-staging-patchset-data")
> - (version "8.0")
> + (version "8.18")
> (source
> (origin
> (method git-fetch)
> @@ -313,10 +313,10 @@ (define-public wine-staging-patchset-data
> (commit (string-append "v" version))))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
> + (base32 "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
> (build-system trivial-build-system)
> (native-inputs
> - (list bash coreutils))
> + (list coreutils))
> (arguments
> `(#:modules ((guix build utils))
> #:builder
> @@ -324,16 +324,12 @@ (define-public wine-staging-patchset-data
> (use-modules (guix build utils))
> (let* ((build-directory ,(string-append name "-" version))
> (source (assoc-ref %build-inputs "source"))
> - (bash (assoc-ref %build-inputs "bash"))
> (coreutils (assoc-ref %build-inputs "coreutils"))
> (out (assoc-ref %outputs "out"))
> (wine-staging (string-append out "/share/wine-staging")))
> (copy-recursively source build-directory)
> (with-directory-excursion build-directory
> - (substitute* "patches/patchinstall.sh"
> - (("/bin/sh")
> - (string-append bash "/bin/sh")))
> - (substitute* "patches/gitapply.sh"
> + (substitute* '("patches/gitapply.sh" "staging/patchinstall.py")
> (("/usr/bin/env")
> (string-append coreutils "/bin/env"))))
> (copy-recursively build-directory wine-staging)
> @@ -363,7 +359,7 @@ (define-public wine-staging
> "wine-" wine-version ".tar.xz"))
> (file-name (string-append name "-" wine-version ".tar.xz"))
> (sha256
> - (base32 "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
> + (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
> (inputs (modify-inputs (package-inputs wine)
> (prepend autoconf ; for autoreconf
> ffmpeg
> @@ -373,6 +369,9 @@ (define-public wine-staging
> python
> util-linux ; for hexdump
> wine-staging-patchset-data)))
> + (native-inputs
> + (modify-inputs (package-native-inputs wine)
> + (prepend python-3)))
> (arguments
> (substitute-keyword-arguments (package-arguments wine)
> ((#:phases phases)
> @@ -382,7 +381,7 @@ (define-public wine-staging
> (lambda* (#:key inputs #:allow-other-keys)
> (invoke (search-input-file
> inputs
> - "/share/wine-staging/patches/patchinstall.sh")
> + "/share/wine-staging/staging/patchinstall.py")
> "DESTDIR=."
> "--all")))
> (add-after 'apply-wine-staging-patches 'patch-SHELL
> @@ -417,7 +416,7 @@ (define-public wine64-staging
> (lambda* (#:key inputs #:allow-other-keys)
> (invoke (search-input-file
> inputs
> - "/share/wine-staging/patches/patchinstall.sh")
> + "/share/wine-staging/staging/patchinstall.py")
> "DESTDIR=."
> "--all")))
> (add-after 'apply-wine-staging-patches 'patch-SHELL
> 
> base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34
> --
> 2.41.0
diff mbox series

Patch

diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 400f0e7607..48f7499ba2 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -304,7 +304,7 @@  (define-public wine64
 (define-public wine-staging-patchset-data
   (package
     (name "wine-staging-patchset-data")
-    (version "8.0")
+    (version "8.18")
     (source
      (origin
        (method git-fetch)
@@ -313,10 +313,10 @@  (define-public wine-staging-patchset-data
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "11q9fa1jdrv1pd9piaicgqvidq1c08imkwpqhyzcj5r711rl7581"))))
+        (base32 "0qabyw5139xdfsvzbwbrn1nnqssgwk8mn88mxnq2cdkk9gbjvq56"))))
     (build-system trivial-build-system)
     (native-inputs
-     (list bash coreutils))
+     (list coreutils))
     (arguments
      `(#:modules ((guix build utils))
        #:builder
@@ -324,16 +324,12 @@  (define-public wine-staging-patchset-data
          (use-modules (guix build utils))
          (let* ((build-directory ,(string-append name "-" version))
                 (source (assoc-ref %build-inputs "source"))
-                (bash (assoc-ref %build-inputs "bash"))
                 (coreutils (assoc-ref %build-inputs "coreutils"))
                 (out (assoc-ref %outputs "out"))
                 (wine-staging (string-append out "/share/wine-staging")))
            (copy-recursively source build-directory)
            (with-directory-excursion build-directory
-             (substitute* "patches/patchinstall.sh"
-               (("/bin/sh")
-                (string-append bash "/bin/sh")))
-             (substitute* "patches/gitapply.sh"
+             (substitute* '("patches/gitapply.sh" "staging/patchinstall.py")
                (("/usr/bin/env")
                 (string-append coreutils "/bin/env"))))
            (copy-recursively build-directory wine-staging)
@@ -363,7 +359,7 @@  (define-public wine-staging
                              "wine-" wine-version ".tar.xz"))
          (file-name (string-append name "-" wine-version ".tar.xz"))
          (sha256
-          (base32 "0bkr3klvjy8h4djddr31fvapsi9pc2rsiyhaa7j1lwpq704w4wh2")))))
+          (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih")))))
     (inputs (modify-inputs (package-inputs wine)
               (prepend autoconf ; for autoreconf
                        ffmpeg
@@ -373,6 +369,9 @@  (define-public wine-staging
                        python
                        util-linux ; for hexdump
                        wine-staging-patchset-data)))
+    (native-inputs
+     (modify-inputs (package-native-inputs wine)
+       (prepend python-3)))
     (arguments
      (substitute-keyword-arguments (package-arguments wine)
        ((#:phases phases)
@@ -382,7 +381,7 @@  (define-public wine-staging
               (lambda* (#:key inputs #:allow-other-keys)
                 (invoke (search-input-file
                          inputs
-                         "/share/wine-staging/patches/patchinstall.sh")
+                         "/share/wine-staging/staging/patchinstall.py")
                         "DESTDIR=."
                         "--all")))
             (add-after 'apply-wine-staging-patches 'patch-SHELL
@@ -417,7 +416,7 @@  (define-public wine64-staging
               (lambda* (#:key inputs #:allow-other-keys)
                 (invoke (search-input-file
                          inputs
-                         "/share/wine-staging/patches/patchinstall.sh")
+                         "/share/wine-staging/staging/patchinstall.py")
                         "DESTDIR=."
                         "--all")))
             (add-after 'apply-wine-staging-patches 'patch-SHELL