diff mbox series

[bug#71993,core-updates,1/2] gnu: nss: Don't use libfaketime on 32bit systems.

Message ID b9be0a44b3a7ca7e33d05ee4cefa65d8c16d871d.1720429414.git.mail@cbaines.net
State New
Headers show
Series Don't use libfaketime for key package tests on 32bit systems | expand

Commit Message

Christopher Baines July 8, 2024, 9:03 a.m. UTC
As it fails to build and doesn't seem to work.

* gnu/packages/nss.scm (nss)[arguments]: Only use faketime on 64bit systems.
[native-inputs]: Only include libfaketime on 64bit systems.

Change-Id: I78bc9b7b2010e5b77f6184ffb7c87740ceae241c
---
 gnu/packages/nss.scm | 15 +++++++++++++--
 1 file changed, 13 insertions(+), 2 deletions(-)


base-commit: 75b4a29e12011ae3d1814932591e80dcb0b80aae
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 49276817ae..2162254760 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -215,7 +215,12 @@  (define-public nss
                     ;; leading to test failures:
                     ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To
                     ;; work around that, set the time to roughly the release date.
-                    (invoke "faketime" "2024-01-23" "./nss/tests/all.sh"))
+                    (invoke #$@(if (target-64bit?)
+                                   '("faketime" "2024-01-23")
+                                   ;; libfaketime is currently broken on 32bit
+                                   ;; systems
+                                   '())
+                            "./nss/tests/all.sh"))
                   (format #t "test suite not run~%"))))
           (replace 'install
             (lambda* (#:key outputs #:allow-other-keys)
@@ -240,7 +245,13 @@  (define-public nss
                 (copy-recursively (string-append obj "/lib") lib)))))))
     (inputs (list sqlite zlib))
     (propagated-inputs (list nspr))               ;required by nss.pc.
-    (native-inputs (list perl libfaketime which)) ;for tests
+    (native-inputs
+     `(,perl
+       ,@(if (target-64bit?)
+             (list libfaketime)
+             ;; libfaketime is currently broken on 32bit systems
+             '())
+       ,which)) ;for tests
 
     ;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
     ;; another build is happening concurrently on the same machine.