diff mbox series

[bug#55994,1/3] gnu: Add python-geomet.

Message ID b9b1f63a3588156d5e2819bf11901a824d9e6ce2.1655293324.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#55994,1/3] gnu: Add python-geomet. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel June 15, 2022, 11:42 a.m. UTC
* gnu/packages/python-xyz.scm (python-geomet): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Hartmut Goebel June 15, 2022, 11:46 a.m. UTC | #1
This adds two in Tryton 6.0 packages missing in Guix. Update to 6.2 anf 
6.4 for whole Tryton will come soon. This series is to allow users to 
have a complete (well, one other package still missing) Tryton 6.0 
available.
Hartmut Goebel June 18, 2022, 4:08 p.m. UTC | #2
Patch 4 is the last missing package in Tryton 6.0.
Hartmut Goebel July 4, 2022, 2:14 p.m. UTC | #3
Pushed as fdcd0133b2e452ce6e8bfbfc185cf3123c06cbfa
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f37ca731d5..67e919b1b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29508,3 +29508,23 @@  with it, and it also implements recommendations from the
 and names, built from Unicode CLDR and the IANA subtag registry, if you
 install @code{python-language-data}.")
     (license license:expat)))
+
+(define-public python-geomet
+  (package
+    (name "python-geomet")
+    (version "0.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "geomet" version))
+              (sha256
+               (base32
+                "06rfvadx5dr5xrgsc5bsmqil9c9kff6i13xl988gy0gfg0cl2lnb"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-click python-six))
+    (home-page "https://github.com/geomet/geomet")
+    (synopsis "Convert GeoJSON to WKT/WKB (Well-Known Text/Binary) or
+GeoPackage Binary")
+    (description "This package provides utilities and functions for converting
+GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
+versa.  Extended WKB/WKT are also supported.")
+    (license license:asl2.0)))