diff mbox series

[bug#68910] gnu: Add wasmedge.

Message ID b9abfd65f5c4f23adfc4bc48fe006de523525fd3.1706981201.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#68910] gnu: Add wasmedge. | expand

Commit Message

Z572 Feb. 3, 2024, 5:26 p.m. UTC
* gnu/packages/web.scm (wasmedge): New variable.

Change-Id: I62a5bbe0e228f0b743bee4d55c4948c61bbfc969
---
 gnu/packages/web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 179bb57d2532ee6b81791e078b0f782cbf88cb84

Comments

Sharlatan Hellseher Feb. 19, 2024, 7:44 p.m. UTC | #1
Hi,

Thank you for the patch.

QA is green.

May you provide more info if you try to enable tests and which
 issues you could not resolve?

Thanks,
Oleg
Sharlatan Hellseher Feb. 19, 2024, 7:48 p.m. UTC | #2
There is some documentation on how to build/run tests
https://wasmedge.org/docs/contribute/source/build_from_src#run-tests
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1a97dd8dec..194b7ac02a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -66,6 +66,7 @@ 
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -165,6 +166,8 @@  (define-module (gnu packages web)
   #:use-module (gnu packages lisp-xyz)
   #:use-module (gnu packages lsof)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages llvm)
+  #:use-module (gnu packages logging)
   #:use-module (gnu packages mail)
   #:use-module (gnu packages man)
   #:use-module (gnu packages markup)
@@ -1774,6 +1777,37 @@  (define-public wasm-micro-runtime
 features.")
     (license license:asl2.0)))
 
+
+(define-public wasmedge
+  (package
+    (name "wasmedge")
+    (version "0.13.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/WasmEdge/WasmEdge")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1l5rr0rma6n17d2khgac79azqjc9sl3r0vljjzc1aw9hhalmm895"))))
+    (build-system cmake-build-system)
+    (native-inputs (list googletest))
+    (inputs (list llvm-17 lld-17 spdlog))
+    (arguments
+     (list
+      ;; TODO: enable test
+      ;; #:configure-flags #~(list "-DWASMEDGE_BUILD_TESTS=ON")
+      #:tests? #f))
+    (home-page "https://wasmedge.org/")
+    (synopsis "High performance WebAssembly Virtual Machine")
+    (description
+     "WasmEdge is a lightweight, high-performance, and extensible
+WebAssembly runtime for cloud native, edge, and decentralized applications.
+It powers serverless apps, embedded functions, microservices, smart contracts,
+and IoT devices.")
+    (license (list license:asl2.0 license:cc0))))
+
 (define-public websocketpp
   (package
     (name "websocketpp")