diff mbox series

[bug#52659,v3,1/2] gnu: Add python-pytest-faulthandler.

Message ID b960924583def5400b477d3eea839c78ec8cf950.1639942526.git.leo@famulari.name
State Accepted
Headers show
Series [bug#52659,v3,1/2] gnu: Add python-pytest-faulthandler. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Dec. 19, 2021, 7:35 p.m. UTC
* gnu/packages/check.scm (python-pytest-faulthandler): New variable.
---
 gnu/packages/check.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0a90a3b167..e3bb53dae0 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
@@ -1481,6 +1481,26 @@  (define-public python-pytest-forked
 side-effects (such as setting environment variables).")
     (license license:expat)))
 
+;; This package is included in Pytest >=5.0.
+(define-public python-pytest-faulthandler
+  (package
+    (name "python-pytest-faulthandler")
+    (version "2.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pytest-faulthandler" version))
+              (sha256
+               (base32
+                "1r8ssxfdib2d2mblmnm34q84lza5d8cq5n5p3sl4sd5chz7bnwpd"))))
+    (build-system python-build-system)
+    (native-inputs
+      (list python-pytest python-setuptools-scm))
+    (home-page "https://github.com/pytest-dev/pytest-faulthandler")
+    (synopsis "Pytest plugin that activates the faulthandler module for tests")
+    (description "This package provides a pytest plugin that automatically
+enables the @code{faulthandler} module during tests.")
+    (license license:expat)))
+
 (define-public python-scripttest
   (package
     (name "python-scripttest")