diff mbox series

[bug#71984,v2,2/2] gnu: python-pygments: Update to 2.18.0.

Message ID b94b1caa87460dba9aa63a985e9729d86ac7321b.1720464215.git.felgru@posteo.net
State New
Headers show
Series [bug#71984,v2,1/2] gnu: python-pygments: Update to 2.15.1. | expand

Commit Message

Felix Gruber July 8, 2024, 6:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Add python-hatchling.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
 gnu/packages/python-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

jgart July 8, 2024, 7:42 p.m. UTC | #1
Hi Sharlatan,

You had mentioned previously being able to test patches that require a lot of builds on your own build machine.

Could you test this v2 that Felix just sent to bug#71984 along with all top-level dependent packages that would need to be rebuilt as a result of it (guix refresh -l) when you get a chance and reply back to us with the result?

QA doesn't seem to be working for ticket #71984.

Thanks!

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 05d4a8b710..4cd971fbaa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7019,14 +7019,14 @@  (define-public python-doc8
 (define-public python-pygments
   (package
     (name "python-pygments")
-    (version "2.15.1")
+    (version "2.18.0")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "Pygments" version))
+       (uri (pypi-uri "pygments" version))
        (sha256
         (base32
-         "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+         "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -7035,7 +7035,7 @@  (define-public python-pygments
       ;; basic tests.
       '(list "--ignore-glob=tests/*/*")))
     (native-inputs
-     (list python-pytest))
+     (list python-hatchling python-pytest))
     (home-page "https://pygments.org/")
     (synopsis "Syntax highlighting")
     (description