diff mbox series

[bug#69871,v3,1/2] gnu: flint: Update to 3.1.2.

Message ID b92c3964a70bfe88a918e4e64f456615b899049e.1710860525.git.andreas@enge.fr
State New
Headers show
Series [bug#69871,v3,1/2] gnu: flint: Update to 3.1.2. | expand

Commit Message

Andreas Enge March 19, 2024, 3:02 p.m. UTC
* gnu/packages/algebra.scm (flint): Update to 3.1.2.
[arguments]: Add a configure flag.
[license]: Change to lgpl3+.

Change-Id: I57d6dc7e1ce90399d9e4c01b35e62793bfc07bee
---
 gnu/packages/algebra.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: ee11b22fcc7d8b42847e9d940ce5be3bc0d4f880
diff mbox series

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3fb9362b91..c8601e7f78 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -446,20 +446,24 @@  (define-public giac
 (define-public flint
   (package
    (name "flint")
-   (version "3.0.1")
+   (version "3.1.2")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://flintlib.org/flint-" version ".tar.gz"))
       (sha256
-       (base32 "1d4lawfvmjd4n7rp4z9xkwwjjbrjhkmxnxw1xf0ki1isa001lcbv"))))
+       (base32 "0017bjncpx4kdx67qcnm3nahz3gyyi2w3ggkrx586r3llcqs9czx"))))
    (build-system gnu-build-system)
    (inputs
     (list ntl))
    (propagated-inputs
-    (list gmp mpfr)) ; header files from both are included by flint/arith.h
+    (list gmp mpfr)) ; header files included by flint.h or mpfr_mat.h
    (arguments
-    `(#:parallel-tests? #f))            ; seems to be necessary on arm
+      ;; Parallel tests failed in the past on ARM, this may need to be
+      ;; tested again.
+    `(#:parallel-tests? #f
+      ;; Prevent build machine specifics from ending up in the binary.
+      #:configure-flags '("--disable-assembly")))
    (synopsis "Fast library for number theory")
    (description
     "FLINT is a C library for number theory.  It supports arithmetic
@@ -472,7 +476,7 @@  (define-public flint
 GCDs, factoring, solving linear systems, and evaluating special
 functions.  In addition, FLINT provides various low-level routines for
 fast arithmetic.")
-   (license license:lgpl2.1+)
+   (license license:lgpl3+)
    (home-page "https://flintlib.org/")
    (properties
     '((release-monitoring-url . "http://flintlib.org/downloads.html")))))
@@ -996,7 +1000,8 @@  (define-public eigen
                   (guix build utils)
                   (guix build cmake-build-system))
 
-       #:phases (modify-phases %standard-phases
+       #:phases
+       (modify-phases %standard-phases
                   (add-after 'unpack 'disable-some-tests
                     ;; Not all platforms are well supported by the test suite.
                     (lambda _