diff mbox series

[bug#50016] gnu: gnuradio: Don't include QtWebKit in the dependency graph.

Message ID b92309b501818337ca829f942b5b61190baf746d.1628719874.git.leo@famulari.name
State Accepted
Headers show
Series [bug#50016] gnu: gnuradio: Don't include QtWebKit in the dependency graph. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Aug. 11, 2021, 10:11 p.m. UTC
This changes affects two leaf packages: gqrx and gr-satellites.

I tested that gqrx still works. I'm not sure how to use gr-satellites.

* gnu/packages/radio.scm (gnuradio)[inputs]: Replace python-pyqt with
python-pyqt-without-qtwebkit.
---
 gnu/packages/radio.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Leo Famulari Aug. 11, 2021, 10:17 p.m. UTC | #1
I am proposing this change because:

1) QtWebKit is hard to keep building:

<https://bugs.gnu.org/50014>

2) QtWebKit is not really "ready" to be used, being an alpha release
with a huge caveat from upstream:

"WARNING: This release is based on old WebKit revision with known
unpatched vulnerabilities. Please use it carefully and avoid visiting
untrusted websites and using it for transmission of sensitive data.
Please wait for new release from qtwebkit-dev branch to use it with
untrusted content."
https://github.com/qtwebkit/qtwebkit/releases/tag/qtwebkit-5.212.0-alpha4
https://seclists.org/oss-sec/2021/q3/66

3) It doesn't seem to be used by gnuradio, although I'm not 100% sure.
It's not mentioned in the gnuradio build log, anyways.
Guillaume Le Vaillant Aug. 12, 2021, 7:29 a.m. UTC | #2
Leo Famulari <leo@famulari.name> skribis:

> I am proposing this change because:
>
> 1) QtWebKit is hard to keep building:
>
> <https://bugs.gnu.org/50014>
>
> 2) QtWebKit is not really "ready" to be used, being an alpha release
> with a huge caveat from upstream:
>
> "WARNING: This release is based on old WebKit revision with known
> unpatched vulnerabilities. Please use it carefully and avoid visiting
> untrusted websites and using it for transmission of sensitive data.
> Please wait for new release from qtwebkit-dev branch to use it with
> untrusted content."
> https://github.com/qtwebkit/qtwebkit/releases/tag/qtwebkit-5.212.0-alpha4
> https://seclists.org/oss-sec/2021/q3/66
>
> 3) It doesn't seem to be used by gnuradio, although I'm not 100% sure.
> It's not mentioned in the gnuradio build log, anyways.

gr-satellites has some functions using HTTP connections, but it's using
python-requests for that, not qtwebkit.
So it looks like nothing based on gnuradio actually depends on qtwebkit,
and your patch will not cause any issue.
Leo Famulari Aug. 15, 2021, 6:04 p.m. UTC | #3
On Thu, Aug 12, 2021 at 07:29:28AM +0000, Guillaume Le Vaillant wrote:
> gr-satellites has some functions using HTTP connections, but it's using
> python-requests for that, not qtwebkit.
> So it looks like nothing based on gnuradio actually depends on qtwebkit,
> and your patch will not cause any issue.

Thanks for the advice. I've gone ahead and pushed as
6ebba295038a84bdeb84adf7652c9a4409ca3d90
diff mbox series

Patch

diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index b0c5d960ed..4ca0bf65a7 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -531,7 +531,7 @@  used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
        ("python-numpy" ,python-numpy)
        ("python-pycairo" ,python-pycairo)
        ("python-pygobject" ,python-pygobject)
-       ("python-pyqt" ,python-pyqt)
+       ("python-pyqt" ,python-pyqt-without-qtwebkit)
        ("python-pyyaml" ,python-pyyaml)
        ("qtbase" ,qtbase-5)
        ("qwt" ,qwt)