diff mbox series

[bug#64755] gnu: git-modes -> emacs-git-modes.

Message ID b921bab4f546ca8ce5c4a9c1a9a9887343e75fda.1689886157.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64755] gnu: git-modes -> emacs-git-modes. | expand

Commit Message

Ahmad Draidi July 20, 2023, 8:49 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-git-modes): New variable.
(git-modes): Deprecate variable.
---

This makes the package name consistent when installing it through 'guix package -i' and a variable name in a system declaration file (e.g. /etc/config.scm). It finishes the job in #29582.

Not sure if the deprecation method I used is optimal, since it brings back to life the package name 'git-modes'. However, putting 'emacs-git-modes' in 'old-name' causes 'warning: ambiguous package specification', as expected.

 gnu/packages/emacs-xyz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)


base-commit: 21b718f4d6c3ded8ef50d12f6e9ae6474f74620f

Comments

Liliana Marie Prikler July 21, 2023, 6:27 p.m. UTC | #1
Am Freitag, dem 21.07.2023 um 00:49 +0400 schrieb Ahmad Draidi:
> * gnu/packages/emacs-xyz.scm (emacs-git-modes): New variable.
> (git-modes): Deprecate variable.
> ---
> 
> This makes the package name consistent when installing it through
> 'guix package -i' and a variable name in a system declaration file
> (e.g. /etc/config.scm). It finishes the job in #29582.
> 
> Not sure if the deprecation method I used is optimal, since it brings
> back to life the package name 'git-modes'. However, putting 'emacs-
> git-modes' in 'old-name' causes 'warning: ambiguous package
> specification', as expected.
There is define-deprecated/public, as well as more idiomatic ways of
writing the commit message, i.e. 

gnu: Rename git-modes to emacs-git-modes.

* gnu/packages/emacs-xyz.scm (git-modes): Deprecate and rename to…
(emacs-git-modes): … this.

Cheers
Ahmad Draidi July 22, 2023, 10:15 a.m. UTC | #2
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Freitag, dem 21.07.2023 um 00:49 +0400 schrieb Ahmad Draidi:
>> * gnu/packages/emacs-xyz.scm (emacs-git-modes): New variable.
>> (git-modes): Deprecate variable.
>> ---
>>
>> This makes the package name consistent when installing it 
>> through
>> 'guix package -i' and a variable name in a system declaration 
>> file
>> (e.g. /etc/config.scm). It finishes the job in #29582.
>>
>> Not sure if the deprecation method I used is optimal, since it 
>> brings
>> back to life the package name 'git-modes'. However, putting 
>> 'emacs-
>> git-modes' in 'old-name' causes 'warning: ambiguous package
>> specification', as expected.
> There is define-deprecated/public, as well as more idiomatic 
> ways of
> writing the commit message, i.e.
>
I grepped the repo, but managed to miss 'deprecation.scm' 
somehow. Thanks for the tip.
I updated the patch with 'define-deprecated/public-alias'.

> gnu: Rename git-modes to emacs-git-modes.
>
> * gnu/packages/emacs-xyz.scm (git-modes): Deprecate and rename 
> to…
> (emacs-git-modes): … this.
>
I got the previous commit message from 3aeca58073, which seemed 
weird to me, but I thought it's the way to go.

I'll email the updated patch shortly.
> Cheers

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 550e5d2a65..6e8b2b313c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1261,7 +1261,7 @@  (define-public emacs-project
 some utility functions, and commands using that infrastructure.")
     (license license:gpl3+)))
 
-(define-public git-modes
+(define-public emacs-git-modes
   (package
     (name "emacs-git-modes")
     (version "1.4.1")
@@ -1285,6 +1285,9 @@  (define-public git-modes
 @file{.git/config}.")
     (license license:gpl3+)))
 
+(define-public git-modes
+  (deprecated-package "git-modes" emacs-git-modes))
+
 (define-public emacs-with-editor
   (package
     (name "emacs-with-editor")