diff mbox series

[bug#47913,v2] add netdiscover

Message ID b8b6d5e7c34d9e843e941bfe2c36828d@cock.li
State Accepted
Headers show
Series [bug#47913,v2] add netdiscover | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Justin Veilleux April 20, 2021, 8:43 p.m. UTC
Here you go.


---
  gnu/packages/networking.scm | 26 ++++++++++++++++++++++++++
  1 file changed, 26 insertions(+)

mainly for
+those wireless networks without dhcp server, it also works on 
hub/switched
+networks.  Its based on arp packets, it will send arp requests and 
sniff for
+replies.")
+   (home-page "https://github.com/netdiscover-scanner/netdiscover")
+   (license license:gpl3+)))
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7557fc331..e973a1b26a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4075,3 +4075,29 @@  IPv6 Internet connectivity - it also works over 
IPv4.")
       ;; version. This exception does not (and cannot) modify any 
license terms
       ;; which apply to the Application, with which you must still 
comply
       license:lgpl3)))
+
+(define-public netdiscover
+  (package
+   (name "netdiscover")
+   (version "0.7")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url 
"https://github.com/netdiscover-scanner/netdiscover")
+                  (commit version)))
+            (sha256 (base32 
"0g8w8rlg16dsibxi4dnyn7v7r8wwi5ypd51c4w59j0ps2id0w8yj"))
+            (file-name (string-append "netdiscover-" version))))
+   (arguments `(#:tests? #f)) ;; no tests
+   (build-system gnu-build-system)
+   (inputs `(("libpcap" ,libpcap)
+             ("libnet" ,libnet)))
+   (native-inputs `(("automake" ,automake)
+                    ("autoconf" ,autoconf)))
+   (synopsis "Network address discovery tool")
+   (description
+    "Netdiscover is a network address discovering tool, developed