diff mbox series

[bug#70268,v2,1/1] gnu: Add python-vdf.

Message ID b8a9cbdbcecec66f9322c86d03181c596a1f7733.1713345494.git.steve@futurile.net
State New
Headers show
Series RE: Add python-vdf | expand

Commit Message

Steve George April 17, 2024, 9:34 a.m. UTC
From: Giacomo Leidi via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/python-xyz.scm (python-vdf): New variable.

Reviewed-by: Steve George <steve@futurile.net>

Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..1637f2aa8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6834,6 +6834,24 @@  (define-public python-pygments
      "Pygments is a syntax highlighting package written in Python.")
     (license license:bsd-2)))
 
+(define-public python-vdf
+  (package
+    (name "python-vdf")
+    (version "3.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "vdf" version))
+       (sha256
+        (base32
+         "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/ValvePython/vdf")
+    (synopsis "Work with Valve's VDF text format")
+    (description "This package provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+    (license license:expat)))
+
 (define-public python-pygments-github-lexers
   (package
     (name "python-pygments-github-lexers")