diff mbox series

[bug#70675] gnu: cmake: Update to 3.29.2.

Message ID b8a8b57f-7897-9f52-8877-bf17a294b083@lyrion.ch
State New
Headers show
Series [bug#70675] gnu: cmake: Update to 3.29.2. | expand

Commit Message

Daniel Ziltener April 30, 2024, 2:52 p.m. UTC
---
gnu/packages/cmake.scm | 26 +++++++++-----------------
1 file changed, 9 insertions(+), 17 deletions(-)

(substitute-keyword-arguments (package-arguments cmake-minimal)
@@ -373,10 +366,8 @@ (define-public cmake
(if (%current-target-system)
cmake-minimal-cross
cmake-minimal))
-
;; Enable debugging information for convenience.
((#:build-type _ #f) "RelWithDebInfo")
-
((#:configure-flags flags ''())
#~(append (list "-DSPHINX_INFO=ON" "-DSPHINX_MAN=ON" "-DSPHINX_HTML=ON"
(string-append "-DCMAKE_DOC_DIR=share/doc/cmake-"
@@ -401,7 +392,8 @@ (define-public cmake
(delete-file-recursively (string-append #$output html)))))))))
(inputs
(modify-inputs (package-inputs cmake-minimal)
- (prepend ncurses))) ;required for ccmake
+ (prepend ncurses) ;required for ccmake
+ (prepend cppdap)))
;; Extra inputs required to build the documentation.
(native-inputs
(modify-inputs (package-native-inputs cmake-minimal)
diff mbox series

Patch

diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 0c780fe420..d9cf9851e1 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -347,24 +347,17 @@  (define preserved-files 
',%preserved-third-party-files)
(define-public cmake
(package
(inherit cmake-minimal)
+ (version "3.29.2")
(name "cmake")
- (version "3.25.1")
(source (origin
- (inherit (package-source cmake-minimal))
- (method url-fetch)
- (uri (string-append "https://cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (snippet (match (origin-snippet (package-source cmake-minimal))
- (('begin ('define 'preserved-files ('quote x))
- rest ...)
- `(begin (define preserved-files
- ',(cons "Utilities/cmelf" x))
- ,@rest))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.kitware.com/cmake/cmake")
+ (commit (string-append "v" version))
+ (recursive? #t)))
(sha256
(base32
- "1n4inb3fvk70sni5gmkljqw3cyllalyg3fnr9rlr7x3aa44isl8w"))
- (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
+ "0yjk4kqrln8smz457dxansfl69zyikr5015xm23xa4g7x1rihkgg"))))
(outputs '("out" "doc"))
(arguments